summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-paginator.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-paginator.spec')
-rw-r--r--php-zendframework-zend-paginator.spec15
1 files changed, 9 insertions, 6 deletions
diff --git a/php-zendframework-zend-paginator.spec b/php-zendframework-zend-paginator.spec
index 2caae2e..aacba47 100644
--- a/php-zendframework-zend-paginator.spec
+++ b/php-zendframework-zend-paginator.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-paginator
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 655b9ef28092b283e10e6c6a4f42c82db992b2ba
+%global gh_commit fd58828c8280a90f133b9e0af2fe1a7885d47206
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-paginator
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.8.0
+Version: 2.8.1
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -41,14 +41,14 @@ BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# "zendframework/zend-cache": "^2.6.1",
# "zendframework/zend-coding-standard": "~1.0.0",
# "zendframework/zend-config": "^2.6.0",
-# "zendframework/zend-db": "^2.7",
+# "zendframework/zend-db": "^2.9.2",
# "zendframework/zend-filter": "^2.6.1",
# "zendframework/zend-json": "^2.6.1",
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
# "zendframework/zend-view": "^2.6.3"
BuildRequires: php-composer(%{gh_owner}/zend-cache) >= 2.6.1
BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.6.0
-BuildRequires: php-composer(%{gh_owner}/zend-db) >= 2.7
+BuildRequires: php-composer(%{gh_owner}/zend-db) >= 2.9.2
BuildRequires: php-composer(%{gh_owner}/zend-filter) >= 2.6.1
BuildRequires: php-composer(%{gh_owner}/zend-json) >= 2.6.1
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
@@ -131,7 +131,7 @@ require_once '%{php_home}/Zend/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" php70 php71 php72; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
@@ -152,6 +152,9 @@ exit $ret
%changelog
+* Wed Jan 31 2018 Remi Collet <remi@remirepo.net> - 2.8.1-1
+- Update to 2.8.1
+
* Thu Nov 2 2017 Remi Collet <remi@remirepo.net> - 2.8.0-1
- Update to 2.8.0
- raise dependency on PHP 5.6