summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-04-26 16:10:04 +0200
committerRemi Collet <remi@remirepo.net>2018-04-26 16:10:04 +0200
commit557dc5e34de34970429fb2f521a7689c55605934 (patch)
treee7850cd8f5dc64c228a9962989245501ad57be70
parentda4d12844adc0f5363473ad604185c825fe79edf (diff)
update to 2.9.0
raise dependency on PHP 5.6
-rw-r--r--composer.json70
-rw-r--r--php-zendframework-zend-navigation.spec68
2 files changed, 69 insertions, 69 deletions
diff --git a/composer.json b/composer.json
index 3016210..1df5536 100644
--- a/composer.json
+++ b/composer.json
@@ -1,60 +1,69 @@
{
"name": "zendframework/zend-navigation",
- "description": "provides support for managing trees of pointers to web pages",
+ "description": "Manage trees of pointers to web pages in order to build navigation systems",
"license": "BSD-3-Clause",
"keywords": [
- "zf2",
+ "zendframework",
+ "zf",
"navigation"
],
- "homepage": "https://github.com/zendframework/zend-navigation",
- "autoload": {
- "psr-4": {
- "Zend\\Navigation\\": "src/"
- }
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-navigation/",
+ "issues": "https://github.com/zendframework/zend-navigation/issues",
+ "source": "https://github.com/zendframework/zend-navigation",
+ "rss": "https://github.com/zendframework/zend-navigation/releases.atom",
+ "chat": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
},
"require": {
- "php": "^5.5 || ^7.0",
+ "php": "^5.6 || ^7.0",
"zendframework/zend-stdlib": "^2.7 || ^3.0"
},
"require-dev": {
- "zendframework/zend-config": "^2.6",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
+ "zendframework/zend-coding-standard": "~1.0.0",
+ "zendframework/zend-config": "^2.6 || ^3.1",
"zendframework/zend-console": "^2.6",
- "zendframework/zend-http": "^2.5.4",
- "zendframework/zend-i18n": "^2.6",
- "zendframework/zend-log": "^2.7.1",
- "zendframework/zend-mvc": "^2.7.9 || ^3.0",
- "zendframework/zend-router": "^3.0",
+ "zendframework/zend-http": "^2.6",
+ "zendframework/zend-i18n": "^2.7.3",
+ "zendframework/zend-log": "^2.9.1",
+ "zendframework/zend-mvc": "^2.7.9 || ^3.0.4",
"zendframework/zend-permissions-acl": "^2.6",
+ "zendframework/zend-router": "^3.0.2",
"zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
- "zendframework/zend-uri": "^2.5",
- "zendframework/zend-view": "^2.6.5",
- "phpunit/phpunit": "^4.6",
- "zendframework/zend-coding-standard": "~1.0.0"
+ "zendframework/zend-uri": "^2.5.2",
+ "zendframework/zend-view": "^2.9"
},
"suggest": {
- "zendframework/zend-config": "^2.6, to provide page configuration (optional, as arrays and Traversables are also allowed)",
+ "zendframework/zend-config": "^2.6 || ^3.1, to provide page configuration (optional, as arrays and Traversables are also allowed)",
"zendframework/zend-permissions-acl": "^2.6, to provide ACL-based access restrictions to pages",
"zendframework/zend-router": "^3.0, to use router-based URI generation with Mvc pages",
"zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3, to use the navigation factories",
- "zendframework/zend-view": "^2.6.5, to use the navigation view helpers"
+ "zendframework/zend-view": "^2.8.1, to use the navigation view helpers"
+ },
+ "autoload": {
+ "psr-4": {
+ "Zend\\Navigation\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "ZendTest\\Navigation\\": "test/"
+ }
+ },
+ "config": {
+ "sort-packages": true
},
- "minimum-stability": "dev",
- "prefer-stable": true,
"extra": {
"branch-alias": {
- "dev-master": "2.8-dev",
- "dev-develop": "2.9-dev"
+ "dev-master": "2.9.x-dev",
+ "dev-develop": "2.10.x-dev"
},
"zf": {
"component": "Zend\\Navigation",
"config-provider": "Zend\\Navigation\\ConfigProvider"
}
},
- "autoload-dev": {
- "psr-4": {
- "ZendTest\\Navigation\\": "test/"
- }
- },
"scripts": {
"check": [
"@cs-check",
@@ -63,7 +72,6 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
- "upload-coverage": "coveralls -v"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
}
diff --git a/php-zendframework-zend-navigation.spec b/php-zendframework-zend-navigation.spec
index 5d81263..42901be 100644
--- a/php-zendframework-zend-navigation.spec
+++ b/php-zendframework-zend-navigation.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit bcf78525bcfdb7956a516f0a122e5b3fde649d97
+%global gh_commit a8b088f64929e172617e02d2089cc00573a61210
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-navigation
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.8.2
+Version: 2.9.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -33,60 +33,48 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# From composer, "require-dev": {
-# "zendframework/zend-config": "^2.6",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
+# "zendframework/zend-coding-standard": "~1.0.0",
+# "zendframework/zend-config": "^2.6 || ^3.1",
# "zendframework/zend-console": "^2.6",
-# "zendframework/zend-http": "^2.5.4",
-# "zendframework/zend-i18n": "^2.6",
-# "zendframework/zend-log": "^2.7.1",
-# "zendframework/zend-mvc": "^2.7.9 || ^3.0",
-# "zendframework/zend-router": "^3.0",
+# "zendframework/zend-http": "^2.6",
+# "zendframework/zend-i18n": "^2.7.3",
+# "zendframework/zend-log": "^2.9.1",
+# "zendframework/zend-mvc": "^2.7.9 || ^3.0.4",
# "zendframework/zend-permissions-acl": "^2.6",
+# "zendframework/zend-router": "^3.0.2",
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
-# "zendframework/zend-uri": "^2.5",
-# "zendframework/zend-view": "^2.6.5",
-# "phpunit/phpunit": "^4.6",
-# "zendframework/zend-coding-standard": "~1.0.0"
+# "zendframework/zend-uri": "^2.5.2",
+# "zendframework/zend-view": "^2.9"
BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-console) >= 2.6
-BuildRequires: php-composer(%{gh_owner}/zend-http) >= 2.5.4
-BuildRequires: php-composer(%{gh_owner}/zend-i18n) >= 2.6
-BuildRequires: php-composer(%{gh_owner}/zend-log) >= 2.7.1
-BuildRequires: php-composer(%{gh_owner}/zend-mvc) >= 2.7
-BuildRequires: php-composer(%{gh_owner}/zend-router) >= 3.0
+BuildRequires: php-composer(%{gh_owner}/zend-http) >= 2.6
+BuildRequires: php-composer(%{gh_owner}/zend-i18n) >= 2.7.3
+BuildRequires: php-composer(%{gh_owner}/zend-log) >= 2.9.1
+BuildRequires: php-composer(%{gh_owner}/zend-mvc) >= 2.7.9
BuildRequires: php-composer(%{gh_owner}/zend-permissions-acl) >= 2.6
+# we ignore 3.0.2 and skip testCanCreateNavigationInstanceV2 (mvc v3)
+BuildRequires: php-composer(%{gh_owner}/zend-router) >= 3.0
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
-BuildRequires: php-composer(%{gh_owner}/zend-uri) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-view) >= 2.6.5
-BuildRequires: php-composer(phpunit/phpunit) >= 4.6
+BuildRequires: php-composer(%{gh_owner}/zend-uri) >= 2.5.2
+BuildRequires: php-composer(%{gh_owner}/zend-view) >= 2.9
+BuildRequires: php-composer(phpunit/phpunit) >= 5.7
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": "^5.5 || ^7.0",
+# "php": "^5.6 || ^7.0",
# "zendframework/zend-stdlib": "^2.7 || ^3.0"
-Requires: php(language) >= 5.5
+Requires: php(language) >= 5.6
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
-# From composer, "suggest": {
-# "zendframework/zend-config": "^2.6, to provide page configuration (optional, as arrays and Traversables are also allowed)",
-# "zendframework/zend-permissions-acl": "^2.6, to provide ACL-based access restrictions to pages",
-# "zendframework/zend-router": "^3.0, to use router-based URI generation with Mvc pages",
-# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3, to use the navigation factories",
-# "zendframework/zend-view": "^2.6.5, to use the navigation view helpers"
-%if 0%{?fedora} >= 21
-Suggests: php-composer(%{gh_owner}/zend-config)
-Suggests: php-composer(%{gh_owner}/zend-permissions-acl)
-Suggests: php-composer(%{gh_owner}/zend-servicemanager)
-Suggests: php-composer(%{gh_owner}/zend-router)
-Suggests: php-composer(%{gh_owner}/zend-view)
-%endif
%endif
# From phpcompatinfo report for version 2.6.0
Requires: php-pcre
@@ -137,9 +125,9 @@ require_once '%{php_home}/Zend/autoload.php';
EOF
ret=0
-for cmd in php php56 php70 php71 php72; do
+for cmd in php php70 php71 php72; do
if which $cmd; then
- $cmd %{_bindir}/phpunit || ret=1
+ $cmd %{_bindir}/phpunit --filter '^((?!(testCanCreateNavigationInstanceV2)).)*$' || ret=1
fi
done
exit $ret
@@ -157,6 +145,10 @@ exit $ret
%changelog
+* Thu Apr 26 2018 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- update to 2.9.0
+- raise dependency on PHP 5.6
+
* Thu Mar 23 2017 Remi Collet <remi@remirepo.net> - 2.8.2-1
- Update to 2.8.2