summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-29 11:17:44 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-29 11:17:44 +0200
commitd1042893b11406f060714ce2296277fb6073d15e (patch)
treedb5f56c1770ebce06d5d5785e5044b5af1dace8a
php-zendframework-zend-mvc-plugin-flashmessenger: 1.0.0 (New package)
-rw-r--r--Makefile3
-rw-r--r--composer.json52
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-zendframework-zend-mvc-plugin-flashmessenger.spec155
4 files changed, 238 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..a2cd659
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,3 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..ec50175
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,52 @@
+{
+ "name": "zendframework/zend-mvc-plugin-flashmessenger",
+ "description": " ",
+ "license": "BSD-3-Clause",
+ "keywords": [
+ "zf2",
+ "mvc"
+ ],
+ "homepage": "https://github.com/zendframework/zend-mvc-plugin-flashmessenger",
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.0-dev"
+ },
+ "zf": {
+ "component": "Zend\\Mvc\\Plugin\\FlashMessenger"
+ }
+ },
+ "autoload": {
+ "psr-4": {
+ "Zend\\Mvc\\Plugin\\FlashMessenger\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "ZendTest\\Mvc\\Plugin\\FlashMessenger\\": "test/"
+ }
+ },
+ "require": {
+ "php": "^5.6 || ^7.0",
+ "zendframework/zend-mvc": "^3.0",
+ "zendframework/zend-session": "^2.6.2",
+ "zendframework/zend-stdlib": "^2.7 || ^3.0"
+ },
+ "require-dev": {
+ "phpunit/PHPUnit": "^4.5",
+ "squizlabs/php_codesniffer": "^2.3.1"
+ },
+ "conflict": {
+ "zendframework/zend-mvc": "<3.0.0"
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "upload-coverage": "coveralls",
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit",
+ "test-coverage": "phpunit --coverage-clover clover.xml"
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..87d223d
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-zendframework-zend-mvc-plugin-flashmessenger.spec b/php-zendframework-zend-mvc-plugin-flashmessenger.spec
new file mode 100644
index 0000000..0b50058
--- /dev/null
+++ b/php-zendframework-zend-mvc-plugin-flashmessenger.spec
@@ -0,0 +1,155 @@
+# remirepo/Fedora spec file for php-zendframework-zend-mvc-plugin-flashmessenger
+#
+# Copyright (c) 2016 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit 712bffa12c955a06d1e4303ab90026486b5b8586
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zend-mvc-plugin-flashmessenger
+%global php_home %{_datadir}/php
+%global library FlashMessenger
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 1.0.0
+Release: 1%{?dist}
+Summary: Zend Framework Mvc-Plugin-%{library} component
+
+Group: Development/Libraries
+License: BSD
+URL: http://framework.zend.com/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.6
+BuildRequires: php-composer(container-interop/container-interop) >= 1.1
+BuildRequires: php-composer(%{gh_owner}/zend-mvc) >= 3.0
+BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.6.2
+BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7.5
+BuildRequires: php-spl
+# From composer, "require-dev": {
+# "phpunit/PHPUnit": "^4.5",
+# "squizlabs/php_codesniffer": "^2.3.1"
+BuildRequires: php-composer(phpunit/phpunit) >= 4.5
+BuildRequires: php-composer(%{gh_owner}/zend-filter) >= 2.6.1
+BuildRequires: php-composer(%{gh_owner}/zend-form) >= 2.7
+# Autoloader
+BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
+%endif
+
+# From composer, "require": {
+# "php": "^5.6 || ^7.0",
+# "zendframework/zend-mvc": "^3.0",
+# "zendframework/zend-session": "^2.6.2",
+# "zendframework/zend-stdlib": "^2.7 || ^3.0"
+Requires: php(language) >= 5.6
+Requires: php-composer(%{gh_owner}/zend-mvc) >= 3.0
+Requires: php-composer(%{gh_owner}/zend-mvc) < 4
+Requires: php-composer(%{gh_owner}/zend-session) >= 2.6.2
+Requires: php-composer(%{gh_owner}/zend-session) < 3
+Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
+Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
+# From phpcompatinfo report for version 1.0.0
+Requires: php-spl
+%if ! %{bootstrap}
+# Autoloader
+Requires: php-composer(%{gh_owner}/zend-loader) >= 2.5
+%endif
+
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+Flash messages derive from Rails, and are used to expose messages from one
+action to the next, after which they are cleared; a typical use case is with
+Post/Redirect/Get, where they are created in the POST handler, and then
+displayed by the GET handler to indicate success or failure to the end-user.
+
+This component provides a flash messenger controller plugin for zend-mvc
+versions 3.0 and up.
+
+* File issues at https://github.com/zendframework/zend-mvc-plugin-flashmessenger/issues
+* Documentation is at https://zendframework.github.io/zend-mvc-plugin-flashmessenger/
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+# Empty build section, nothing required
+
+
+%install
+rm -rf %{buildroot}
+
+mkdir -p %{buildroot}%{php_home}/Zend/Mvc/Plugin
+cp -pr src %{buildroot}%{php_home}/Zend/Mvc/Plugin/%{library}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
+ 'namespaces' => array(
+ 'ZendTest\\Mvc\\Plugin\\%{library}' => dirname(__DIR__).'/test/',
+ 'Zend\\Mvc\\Plugin\\%{library}' => '%{buildroot}%{php_home}/Zend/Mvc/Plugin/%{library}'
+))));
+require_once '%{php_home}/Zend/autoload.php';
+EOF
+
+# remirepo:11
+run=0
+ret=0
+if which php56; then
+ php56 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
+ run=1
+fi
+if which php71; then
+ php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
+ run=1
+fi
+if [ $run -eq 0 ]; then
+%{_bindir}/phpunit --include-path=%{buildroot}%{php_home} --verbose
+# remirepo:2
+fi
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE.md
+%doc CHANGELOG.md CONDUCT.md CONTRIBUTING.md README.md
+%doc composer.json
+%{php_home}/Zend/Mvc/Plugin/%{library}
+
+
+%changelog
+* Wed Jun 29 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- initial package
+