summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore7
-rw-r--r--composer.json24
-rw-r--r--php-zendframework-zend-modulemanager.spec47
3 files changed, 50 insertions, 28 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index e34d3cc..76f596d 100644
--- a/composer.json
+++ b/composer.json
@@ -13,36 +13,38 @@
}
},
"require": {
- "php": "^5.5 || ^7.0",
- "zendframework/zend-config": "^2.6 || ^3.1",
- "zendframework/zend-eventmanager": "^2.6.2 || ^3.0",
- "zendframework/zend-stdlib": "^2.7 || ^3.0"
+ "php": "^5.6 || ^7.0",
+ "zendframework/zend-config": "^3.1 || ^2.6",
+ "zendframework/zend-eventmanager": "^3.2 || ^2.6.3",
+ "zendframework/zend-stdlib": "^3.0 || ^2.7"
},
"require-dev": {
"zendframework/zend-console": "^2.6",
"zendframework/zend-di": "^2.6",
"zendframework/zend-loader": "^2.5",
"zendframework/zend-mvc": "^2.7",
- "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
- "phpunit/PHPUnit": "~4.0",
+ "zendframework/zend-servicemanager": "^3.0.3 || ^2.7.5",
+ "phpunit/phpunit": "^6.0.8 || ^5.7.15",
"zendframework/zend-coding-standard": "~1.0.0"
},
"suggest": {
"zendframework/zend-console": "Zend\\Console component",
- "zendframework/zend-loader": "Zend\\Loader component",
+ "zendframework/zend-loader": "Zend\\Loader component if you are not using Composer autoloading for your modules",
"zendframework/zend-mvc": "Zend\\Mvc component",
"zendframework/zend-servicemanager": "Zend\\ServiceManager component"
},
- "minimum-stability": "dev",
- "prefer-stable": true,
"extra": {
"branch-alias": {
- "dev-master": "2.7-dev",
- "dev-develop": "2.8-dev"
+ "dev-master": "2.8-dev",
+ "dev-develop": "2.9-dev"
}
},
"autoload-dev": {
+ "files": [
+ "test/autoload.php"
+ ],
"psr-4": {
+ "ListenerTestModule\\": "test/TestAsset/ListenerTestModule/",
"ZendTest\\ModuleManager\\": "test/"
}
},
diff --git a/php-zendframework-zend-modulemanager.spec b/php-zendframework-zend-modulemanager.spec
index 543597d..40adb8a 100644
--- a/php-zendframework-zend-modulemanager.spec
+++ b/php-zendframework-zend-modulemanager.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 248cf20a5ea08727d84ad7c122110d70c62b48df
+%global gh_commit c2c5b52ad9741e0b9a9c01a0ee72ab63e5b494b9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-modulemanager
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.3
+Version: 2.8.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -33,25 +33,30 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
BuildRequires: php-spl
BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.6
-BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6.3
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# From composer, "require-dev": {
# "zendframework/zend-console": "^2.6",
# "zendframework/zend-di": "^2.6",
# "zendframework/zend-loader": "^2.5",
# "zendframework/zend-mvc": "^2.7",
-# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
-# "phpunit/PHPUnit": "~4.0",
+# "zendframework/zend-servicemanager": "^3.0.3 || ^2.7.5",
+# "phpunit/phpunit": "^6.0.8 || ^5.7.15",
# "zendframework/zend-coding-standard": "~1.0.0"
BuildRequires: php-composer(%{gh_owner}/zend-console) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-di) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
BuildRequires: php-composer(%{gh_owner}/zend-mvc) >= 2.7
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
# Because of bootstrap
BuildRequires: php-composer(%{gh_owner}/zend-code) >= 2.5
# Autoloader
@@ -59,22 +64,22 @@ BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": "^5.5 || ^7.0",
-# "zendframework/zend-config": "^2.6 || ^3.1",
-# "zendframework/zend-eventmanager": "^2.6.2 || ^3.0",
-# "zendframework/zend-stdlib": "^2.7 || ^3.0"
-Requires: php(language) >= 5.5
+# "php": "^5.6 || ^7.0",
+# "zendframework/zend-config": "^3.1 || ^2.6",
+# "zendframework/zend-eventmanager": "^3.2 || ^2.6.3",
+# "zendframework/zend-stdlib": "^3.0 || ^2.7"
+Requires: php(language) >= 5.6
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-config) >= 2.6
Requires: php-composer(%{gh_owner}/zend-config) < 4
-Requires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6.2
+Requires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6.3
Requires: php-composer(%{gh_owner}/zend-eventmanager) < 4
Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
# From composer, "suggest": {
# "zendframework/zend-config": "Zend\\Config component",
# "zendframework/zend-console": "Zend\\Console component",
-# "zendframework/zend-loader": "Zend\\Loader component",
+# "zendframework/zend-loader": "Zend\\Loader component if you are not using Composer autoloading for your modules",
# "zendframework/zend-mvc": "Zend\\Mvc component",
# "zendframework/zend-servicemanager": "Zend\\ServiceManager component"
%if 0%{?fedora} >= 21
@@ -129,16 +134,19 @@ require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
Zend\Loader\AutoloaderFactory::factory(array(
'Zend\Loader\StandardAutoloader' => array(
'namespaces' => array(
+ 'ListenerTestModule' => dirname(__DIR__).'/test/TestAsset/ListenerTestModule/',
'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
+require_once __DIR__ . '/../test/autoload.php';
EOF
ret=0
-for cmd in php php56 php70 php71 php72; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose || ret=1
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
fi
done
exit $ret
@@ -156,6 +164,11 @@ exit $ret
%changelog
+* Wed Jul 12 2017 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- Update to 2.8.0
+- raise dependency on PHP 5.6
+- use phpunit6 on F26+
+
* Wed Jul 12 2017 Remi Collet <remi@remirepo.net> - 2.7.3-1
- Update to 2.7.3