summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-10-21 09:51:44 +0200
committerRemi Collet <remi@remirepo.net>2019-10-21 09:51:44 +0200
commitc9b2681dea4d482b7373c804af4677deeba804d1 (patch)
treefd22aab4b7119fa60be20bf6423276c506e76fba
parent5b8c7b2b9d6d6d71cc83f51b2a73e94042d3b569 (diff)
v2.8.3
-rw-r--r--composer.json14
-rw-r--r--php-zendframework-zend-modulemanager.spec11
2 files changed, 13 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index 4dd8a04..7996142 100644
--- a/composer.json
+++ b/composer.json
@@ -12,7 +12,7 @@
"issues": "https://github.com/zendframework/zend-modulemanager/issues",
"source": "https://github.com/zendframework/zend-modulemanager",
"rss": "https://github.com/zendframework/zend-modulemanager/releases.atom",
- "slack": "https://zendframework-slack.herokuapp.com",
+ "chat": "https://zendframework-slack.herokuapp.com",
"forum": "https://discourse.zendframework.com/c/questions/components"
},
"require": {
@@ -27,7 +27,7 @@
"zendframework/zend-loader": "^2.5",
"zendframework/zend-mvc": "^3.0 || ^2.7",
"zendframework/zend-servicemanager": "^3.0.3 || ^2.7.5",
- "phpunit/phpunit": "^6.0.8 || ^5.7.15",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.16",
"zendframework/zend-coding-standard": "~1.0.0"
},
"suggest": {
@@ -57,8 +57,8 @@
},
"extra": {
"branch-alias": {
- "dev-master": "2.7-dev",
- "dev-develop": "2.8-dev"
+ "dev-master": "2.8.x-dev",
+ "dev-develop": "2.9.x-dev"
}
},
"scripts": {
@@ -69,8 +69,6 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
- "upload-coverage": "coveralls -v"
- },
- "homepage": "https://github.com/zendframework/zend-modulemanager"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ }
}
diff --git a/php-zendframework-zend-modulemanager.spec b/php-zendframework-zend-modulemanager.spec
index 216b589..f254b24 100644
--- a/php-zendframework-zend-modulemanager.spec
+++ b/php-zendframework-zend-modulemanager.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 394df6e12248ac430a312d4693f793ee7120baa6
+%global gh_commit aaba206a955b5f43f29e17d09d19fc342a989b24
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-modulemanager
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.8.2
+Version: 2.8.3
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -44,7 +44,7 @@ BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# "zendframework/zend-loader": "^2.5",
# "zendframework/zend-mvc": "^3.0 || ^2.7",
# "zendframework/zend-servicemanager": "^3.0.3 || ^2.7.5",
-# "phpunit/phpunit": "^6.0.8 || ^5.7.15",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.16",
# "zendframework/zend-coding-standard": "~1.0.0"
BuildRequires: php-composer(%{gh_owner}/zend-console) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-di) >= 2.6
@@ -145,7 +145,7 @@ require_once __DIR__ . '/../test/TestAsset/ModuleAsClass.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" php71 php72; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
@@ -166,6 +166,9 @@ exit $ret
%changelog
+* Mon Oct 21 2019 Remi Collet <remi@remirepo.net> - 2.8.3-1
+- update to 2.8.3
+
* Mon Dec 4 2017 Remi Collet <remi@remirepo.net> - 2.8.2-1
- Update to 2.8.2