From 1412201660290dc054dbd7f03ea5f77cb56e5615 Mon Sep 17 00:00:00 2001
From: Remi Collet <fedora@famillecollet.com>
Date: Tue, 4 Aug 2015 14:19:31 +0200
Subject: php-zendframework-zend-math: 2.5.1 (new, wip)

---
 Makefile                         |   3 +
 makesrc.sh                       |  27 ++++++++
 php-zendframework-zend-math.spec | 138 +++++++++++++++++++++++++++++++++++++++
 3 files changed, 168 insertions(+)
 create mode 100644 Makefile
 create mode 100755 makesrc.sh
 create mode 100644 php-zendframework-zend-math.spec

diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..a2cd659
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,3 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..24fbf81
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,27 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed   -n '/^%global gh_owner/{s/.* //;p}'   $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}'           $NAME.spec)
+COMMIT=$(sed  -n '/^%global gh_commit/{s/.* //;p}'  $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-zendframework-zend-math.spec b/php-zendframework-zend-math.spec
new file mode 100644
index 0000000..6eddbd6
--- /dev/null
+++ b/php-zendframework-zend-math.spec
@@ -0,0 +1,138 @@
+# remirepo spec/Fedora file for php-zendframework-zend-math
+#
+# Copyright (c) 2015 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap    0
+%global gh_commit    9f02a1ac4d3374d3332c80f9215deec9c71558fc
+%global gh_short     %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner     zendframework
+%global gh_project   zend-math
+%global php_home     %{_datadir}/php
+%global library      Math
+%if %{bootstrap}
+%global with_tests   0%{?_with_tests:1}
+%else
+%global with_tests   0%{!?_without_tests:1}
+%endif
+
+Name:           php-%{gh_owner}-%{gh_project}
+Version:        2.5.1
+Release:        1%{?dist}
+Summary:        Zend Framework %{library} component
+
+Group:          Development/Libraries
+License:        BSD
+URL:            http://framework.zend.com/
+Source0:        %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1:        makesrc.sh
+
+BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildArch:      noarch
+# Tests
+%if %{with_tests}
+BuildRequires:  php(language) >= 5.3.23
+BuildRequires:  php-bcmath
+BuildRequires:  php-gmp
+BuildRequires:  php-openssl
+BuildRequires:  php-pcre
+BuildRequires:  php-spl
+# From composer, "require-dev": {
+#        "fabpot/php-cs-fixer": "1.7.*",
+#        "ircmaxell/random-lib": "~1.1",
+#        "phpunit/PHPUnit": "~4.0",
+#        "zendframework/zend-servicemanager": "~2.5"
+BuildRequires:  php-composer(%{gh_owner}/zend-servicemanager)   >= 2.5
+BuildRequires:  php-composer(ircmaxell/random-lib)              >= 1.1
+BuildRequires:  php-composer(phpunit/phpunit)                   >= 4.0
+# Autoloader
+BuildRequires:  php-composer(%{gh_owner}/zend-loader) >= 2.5
+%endif
+
+# From composer, "require": {
+#        "php": ">=5.3.23"
+Requires:       php(language) >= 5.3.23
+# From phpcompatinfo report for version 2.5.2
+Requires:       php-openssl
+Requires:       php-pcre
+Requires:       php-spl
+%if ! %{bootstrap}
+# From composer, "suggest": {
+#        "ext-bcmath": "If using the bcmath functionality",
+#        "ext-gmp": "If using the gmp functionality",
+#        "ircmaxell/random-lib": "Fallback random byte generator for Zend\\Math\\Rand if OpenSSL/Mcrypt extensions are unavailable",
+#        "zendframework/zend-servicemanager": ">= current version, if using the BigInteger::factory functionality"
+Requires:       php-bcmath
+Requires:       php-gmp
+%if 0%{?fedora} >= 21
+Suggests:       php-composer(ircmaxell/random-lib)
+Suggests:       php-composer(%{gh_owner}/zend-servicemanager)
+%endif
+%endif
+
+Obsoletes:      php-ZendFramework2-%{library} < 2.5
+Provides:       php-ZendFramework2-%{library} = %{version}
+Provides:       php-composer(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+Zend\Math provides general mathematical functions.
+So far the supported functionalities are:
+* Zend\Math\Rand, a random number generator;
+* Zend\Math\BigInteger, a library to manage big integers.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+# Empty build section, nothing required
+
+
+%install
+rm -rf %{buildroot}
+
+mkdir -p   %{buildroot}%{php_home}/Zend/
+cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << EOF | tee vendor/autoload.php
+<?php
+require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
+Zend\\Loader\\AutoloaderFactory::factory(array(
+    'Zend\\Loader\\StandardAutoloader' => array(
+        'namespaces' => array(
+           'ZendTest\\\\%{library}' => dirname(__DIR__).'/test/',
+           'Zend\\\\%{library}'     => '%{buildroot}%{php_home}/Zend/%{library}'
+))));
+require_once '%{php_home}/Zend/autoload.php';
+EOF
+%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+%else
+: Test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE.md
+%doc CONTRIBUTING.md README.md
+%doc composer.json
+%{php_home}/Zend/%{library}
+
+
+%changelog
+* Tue Aug  4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
+- initial package
\ No newline at end of file
-- 
cgit