summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-math-dev.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-math-dev.spec')
-rw-r--r--php-zendframework-zend-math-dev.spec192
1 files changed, 192 insertions, 0 deletions
diff --git a/php-zendframework-zend-math-dev.spec b/php-zendframework-zend-math-dev.spec
new file mode 100644
index 0000000..d97d878
--- /dev/null
+++ b/php-zendframework-zend-math-dev.spec
@@ -0,0 +1,192 @@
+# remirepo/Fedora spec file for php-zendframework-zend-math
+#
+# Copyright (c) 2015-2016 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit fda3b4e6c3bb15c35adc6db38b2eacabaa243e65
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zend-math
+%global php_home %{_datadir}/php
+%global library Math
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 3.0.0
+Release: 1%{?dist}
+Summary: Zend Framework %{library} component
+
+Group: Development/Libraries
+License: BSD
+URL: https://framework.zend.com/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.5
+BuildRequires: php-bcmath
+BuildRequires: php-gmp
+BuildRequires: php-openssl
+BuildRequires: php-pcre
+BuildRequires: php-spl
+BuildRequires: php-composer(paragonie/random_compat)
+# test suite hangs without (need investigation)
+BuildRequires: php-mcrypt
+# From composer, "require-dev": {
+# "fabpot/php-cs-fixer": "1.7.*",
+# "phpunit/PHPUnit": "~4.0",
+# "zendframework/zend-servicemanager": "~2.5"
+BuildRequires: php-composer(ircmaxell/random-lib) >= 1.1
+BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+# Autoloader
+BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
+# For dependencies autoloader
+BuildRequires: php-zendframework-zend-loader >= 2.5.1-3
+%endif
+
+# From composer, "require": {
+# "php": "^5.5 || ^7.0",
+# "ext-mbstring": "*",
+# "paragonie/random_compat": "^2.0.2"
+Requires: php(language) >= 5.5
+Requires: php-mbstring
+# ignore min version
+Requires: php-composer(paragonie/random_compat)
+# From phpcompatinfo report for version 2.5.2
+Requires: php-openssl
+Requires: php-pcre
+Requires: php-spl
+Requires: php-zendframework-zend-loader >= 2.5.1-3
+%if ! %{bootstrap}
+# From composer, "suggest": {
+# "ext-bcmath": "If using the bcmath functionality",
+# "ext-gmp": "If using the gmp functionality",
+Requires: php-bcmath
+Requires: php-gmp
+# Autoloader
+Requires: php-composer(%{gh_owner}/zend-loader) >= 2.5
+%endif
+
+Obsoletes: php-ZendFramework2-%{library} < 2.5
+Provides: php-ZendFramework2-%{library} = %{version}
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+Zend\Math provides general mathematical functions.
+So far the supported functionalities are:
+* Zend\Math\Rand, a random number generator;
+* Zend\Math\BigInteger, a library to manage big integers.
+
+Documentation: https://zendframework.github.io/%{gh_project}/
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+mv LICENSE.md LICENSE
+
+: Create dependency autoloader
+cat << 'EOF' | tee autoload.php
+<?php
+require_once '%{php_home}/random_compat/autoload.php';
+EOF
+
+
+%build
+# Empty build section, nothing required
+
+
+%install
+rm -rf %{buildroot}
+
+mkdir -p %{buildroot}%{php_home}/Zend/
+cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+
+install -m644 autoload.php %{buildroot}%{php_home}/Zend/%{library}-autoload.php
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+define('RPM_BUILDROOT', '%{buildroot}%{php_home}/Zend');
+
+require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
+ 'namespaces' => array(
+ 'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
+ 'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
+))));
+require_once '%{php_home}/Zend/autoload.php';
+EOF
+
+# remirepo:11
+run=0
+ret=0
+if which php56; then
+ php56 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
+ run=1
+fi
+if which php71; then
+ php71 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
+ run=1
+fi
+if [ $run -eq 0 ]; then
+%{_bindir}/phpunit --include-path=%{buildroot}%{php_home} --verbose
+# remirepo:2
+fi
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{php_home}/Zend/%{library}
+%{php_home}/Zend/%{library}-autoload.php
+
+
+%changelog
+* Wed Jun 29 2016 Remi Collet <remi@fedoraproject.org> - 3.0.0-1
+- update to 3.0.0 for ZendFramework 3
+- add dependencies autoloader
+- add dependency on paragonie/random_compat
+- drop dependency on ircmaxell/random-lib
+
+* Fri Apr 8 2016 Remi Collet <remi@fedoraproject.org> - 2.7.0-1
+- update to 2.7.0
+- add mandatory dependency on ircmaxell/random-lib
+
+* Wed Feb 3 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
+- update to 2.6.0
+- drop dependency on zend-servicemanager
+
+* Thu Dec 17 2015 Remi Collet <remi@fedoraproject.org> - 2.5.2-1
+- update to 2.5.2
+- raise minimal php version to 5.5
+
+* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
+- initial package