summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-math.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-24 07:06:20 +0100
committerRemi Collet <remi@remirepo.net>2017-11-24 07:06:20 +0100
commitdf1f70180454483dfde9e6e5f604162625ff2ca1 (patch)
tree7ebc33cbc6ccfdef039669fdded5a5734d45f22c /php-zendframework-zend-math.spec
parentcdcb7d5c97ffb0cced16aff133c29f649cc94c91 (diff)
switch
Diffstat (limited to 'php-zendframework-zend-math.spec')
-rw-r--r--php-zendframework-zend-math.spec77
1 files changed, 49 insertions, 28 deletions
diff --git a/php-zendframework-zend-math.spec b/php-zendframework-zend-math.spec
index 6034e22..08e12ee 100644
--- a/php-zendframework-zend-math.spec
+++ b/php-zendframework-zend-math.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit f4358090d5d23973121f1ed0b376184b66d9edec
+%global gh_commit fda3b4e6c3bb15c35adc6db38b2eacabaa243e65
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-math
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.0
-Release: 3%{?dist}
+Version: 3.0.0
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -30,9 +30,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-# https://github.com/zendframework/zend-math/pull/24
-Patch0: %{name}-pr24.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
@@ -43,37 +40,40 @@ BuildRequires: php-gmp
BuildRequires: php-openssl
BuildRequires: php-pcre
BuildRequires: php-spl
-%if 0%{?fedora} < 25
+BuildRequires: php-composer(paragonie/random_compat)
# test suite hangs without (need investigation)
BuildRequires: php-mcrypt
-%endif
# From composer, "require-dev": {
# "fabpot/php-cs-fixer": "1.7.*",
-# "ircmaxell/random-lib": "~1.1",
# "phpunit/PHPUnit": "~4.0",
# "zendframework/zend-servicemanager": "~2.5"
BuildRequires: php-composer(ircmaxell/random-lib) >= 1.1
BuildRequires: php-composer(phpunit/phpunit) >= 4.0
# Autoloader
-BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
+# For dependencies autoloader
+BuildRequires: php-zendframework-zend-loader >= 2.5.1-3
%endif
# From composer, "require": {
-# "php": "^5.5 || ^7.0"
+# "php": "^5.5 || ^7.0",
+# "ext-mbstring": "*",
+# "paragonie/random_compat": "^2.0.2"
Requires: php(language) >= 5.5
+Requires: php-mbstring
+# ignore min version
+Requires: php-composer(paragonie/random_compat)
# From phpcompatinfo report for version 2.5.2
Requires: php-openssl
Requires: php-pcre
Requires: php-spl
+Requires: php-zendframework-zend-loader >= 2.5.1-3
%if ! %{bootstrap}
# From composer, "suggest": {
# "ext-bcmath": "If using the bcmath functionality",
# "ext-gmp": "If using the gmp functionality",
-# "ircmaxell/random-lib": "Fallback random byte generator for Zend\\Math\\Rand if Mcrypt extensions is unavailable"
Requires: php-bcmath
Requires: php-gmp
-# Mandatory as we don't want mcrypt
-Requires: php-composer(ircmaxell/random-lib)
# Autoloader
Requires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
@@ -89,12 +89,19 @@ So far the supported functionalities are:
* Zend\Math\Rand, a random number generator;
* Zend\Math\BigInteger, a library to manage big integers.
+Documentation: https://zendframework.github.io/%{gh_project}/
+
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-cd src
-%patch0 -p1
+mv LICENSE.md LICENSE
+
+: Create dependency autoloader
+cat << 'EOF' | tee autoload.php
+<?php
+require_once '%{php_home}/random_compat/autoload.php';
+EOF
%build
@@ -107,12 +114,16 @@ rm -rf %{buildroot}
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+install -m644 autoload.php %{buildroot}%{php_home}/Zend/%{library}-autoload.php
+
%check
%if %{with_tests}
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
+define('RPM_BUILDROOT', '%{buildroot}%{php_home}/Zend');
+
require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
Zend\Loader\AutoloaderFactory::factory(array(
'Zend\Loader\StandardAutoloader' => array(
@@ -123,12 +134,22 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-
-# remirepo:3
+# remirepo:11
+run=0
+ret=0
+if which php56; then
+ php56 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
+ run=1
+fi
if which php71; then
- php71 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+ php71 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
+ run=1
+fi
+if [ $run -eq 0 ]; then
+%{_bindir}/phpunit --include-path=%{buildroot}%{php_home} --verbose
+# remirepo:2
fi
+exit $ret
%else
: Test suite disabled
%endif
@@ -141,19 +162,19 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
-%license LICENSE.md
-%doc CONTRIBUTING.md README.md
+%license LICENSE
+%doc *.md
%doc composer.json
%{php_home}/Zend/%{library}
+%{php_home}/Zend/%{library}-autoload.php
%changelog
-* Tue Nov 15 2016 Remi Collet <remi@fedoraproject.org> - 2.7.0-3
-- drop mcrypt build dependency
-
-* Thu Sep 15 2016 Remi Collet <remi@fedoraproject.org> - 2.7.0-2
-- fix FTBFS detected by Koschei, patch from
- https://github.com/zendframework/zend-math/pull/24
+* Wed Jun 29 2016 Remi Collet <remi@fedoraproject.org> - 3.0.0-1
+- update to 3.0.0 for ZendFramework 3
+- add dependencies autoloader
+- add dependency on paragonie/random_compat
+- drop dependency on ircmaxell/random-lib
* Fri Apr 8 2016 Remi Collet <remi@fedoraproject.org> - 2.7.0-1
- update to 2.7.0