summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-log.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-log.spec')
-rw-r--r--php-zendframework-zend-log.spec21
1 files changed, 10 insertions, 11 deletions
diff --git a/php-zendframework-zend-log.spec b/php-zendframework-zend-log.spec
index 91b0b89..0583be0 100644
--- a/php-zendframework-zend-log.spec
+++ b/php-zendframework-zend-log.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-log
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit bf7489578d092d6ff7508117d1d920a4764fbd6a
+%global gh_commit 9cec3b092acb39963659c2f32441cccc56b3f430
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-log
@@ -20,18 +20,15 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.9.2
-Release: 3%{?dist}
+Version: 2.10.0
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
-Group: Development/Libraries
License: BSD
URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: https://patch-diff.githubusercontent.com/raw/zendframework/zend-log/pull/79.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -53,14 +50,14 @@ BuildRequires: php-composer(psr/log) >= 1.0
# "zendframework/zend-escaper": "^2.5",
# "zendframework/zend-filter": "^2.5",
# "zendframework/zend-mail": "^2.6.1",
-# "zendframework/zend-validator": "^2.6"
+# "zendframework/zend-validator": "^2.10.1"
BuildRequires: php-composer(mikey179/vfsStream) >= 1.6
BuildRequires: php-composer(%{gh_owner}/zend-console) >= 2.5
BuildRequires: php-composer(%{gh_owner}/zend-db) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-escaper) >= 2.5
BuildRequires: php-composer(%{gh_owner}/zend-filter) >= 2.5
BuildRequires: php-composer(%{gh_owner}/zend-mail) >= 2.6.1
-BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.6
+BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.10.1
%if 0%{?fedora} >= 26
%global phpunit %{_bindir}/phpunit6
%else
@@ -129,7 +126,6 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
mv LICENSE.md LICENSE
@@ -165,7 +161,7 @@ EOF
rm test/Writer/MongoDBTest.php
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" php70 php71 php72; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
@@ -186,6 +182,9 @@ exit $ret
%changelog
+* Wed Apr 11 2018 Remi Collet <remi@remirepo.net> - 2.10.0-1
+- update to 2.10.0
+
* Tue Oct 24 2017 Remi Collet <remi@remirepo.net> - 2.9.2-3
- fix FTBFS from Koschei, add patch for PHP 7.2 from
https://github.com/zendframework/zend-log/pull/79