summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-zendframework-zend-json.spec57
1 files changed, 23 insertions, 34 deletions
diff --git a/php-zendframework-zend-json.spec b/php-zendframework-zend-json.spec
index 9e35946..e5397ab 100644
--- a/php-zendframework-zend-json.spec
+++ b/php-zendframework-zend-json.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-json
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit f42a1588e75c2a3e338cd94c37906231e616daab
+%global gh_commit 4dd940e8e6f32f1d36ea6b0677ea57c540c7c19c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-json
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 3.0.0
+Version: 3.1.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -30,29 +30,28 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
BuildRequires: php-json
BuildRequires: php-mbstring
BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
# From composer, "require-dev": {
-# "zendframework/zend-stdlib": "^2.7 || ^3.0",
-# "squizlabs/php_codesniffer": "^2.3",
-# "phpunit/PHPUnit": "~4.0"
-BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+# "phpunit/phpunit": "^5.7.23 || ^6.4.3",
+# "zendframework/zend-coding-standard": "~1.0.0",
+# "zendframework/zend-stdlib": "^2.7.7 || ^3.1"
+BuildRequires: php-composer(phpunit/phpunit) >= 5.7.23
+BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7.7
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": "^5.5 || ^7.0",
-Requires: php(language) >= 5.5
+# "php": "^5.6 || ^7.0",
+Requires: php(language) >= 5.6
%if ! %{bootstrap}
# From composer, "suggest": {
# "zendframework/zend-json-server": "For implementing JSON-RPC servers",
@@ -62,12 +61,14 @@ Suggests: php-composer(%{gh_owner}/zend-json-server)
Suggests: php-composer(%{gh_owner}/zend-xml2json)
%endif
%endif
-# From phpcompatinfo report for version 2.6.0
+# From phpcompatinfo report for version 3.1.0
Requires: php-json
Requires: php-mbstring
Requires: php-pcre
Requires: php-reflection
Requires: php-spl
+# Autoloader
+Requires: php-composer(%{gh_owner}/zend-loader) >= 2.5
Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
@@ -92,8 +93,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -113,33 +112,19 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
- run=1
-fi
-if which php71; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home} --verbose
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -148,6 +133,10 @@ rm -rf %{buildroot}
%changelog
+* Fri Jan 5 2018 Remi Collet <remi@remirepo.net> - 3.1.0-1
+- Update to 3.1.0
+- raise dependency on PHP 5.6
+
* Wed Jun 29 2016 Remi Collet <remi@fedoraproject.org> - 3.0.0-1
- update to 3.0.0 for ZendFramework 3
- add optional dependencies on zend-json-server and zend-xml2json