summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-zendframework-zend-i18n.spec8
1 files changed, 7 insertions, 1 deletions
diff --git a/php-zendframework-zend-i18n.spec b/php-zendframework-zend-i18n.spec
index 2a1494d..b38cb28 100644
--- a/php-zendframework-zend-i18n.spec
+++ b/php-zendframework-zend-i18n.spec
@@ -195,7 +195,11 @@ ret=0
for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit7} \
+%if 0%{?fedora} >= 29
+ --filter '^((?!(testSettersProvideDefaults|testBasic)).)*$' \
+%endif
+ --verbose || ret=1
fi
done
exit $ret
@@ -215,6 +219,8 @@ exit $ret
%changelog
* Wed May 23 2018 Remi Collet <remi@remirepo.net> - 2.9.0-2
- update to 2.9.0
+- skip test failing with libicu 61, reported as
+ https://github.com/zendframework/zend-i18n/issues/97
* Thu Apr 26 2018 Remi Collet <remi@remirepo.net> - 2.8.0-2
- update to 2.8.0