summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-09-26 14:31:18 +0200
committerRemi Collet <remi@remirepo.net>2019-09-26 14:31:18 +0200
commitdc5865a167d2c3b9e8031f7e257a263d5701ad05 (patch)
treef910134d31bc264ebafea4da81102668f5876cfb
parente0a03d275c897f53ad6ac7dc8264596c4f965538 (diff)
v2.9.1
-rw-r--r--114.patch22
-rw-r--r--composer.json2
-rw-r--r--php-zendframework-zend-i18n.spec16
3 files changed, 9 insertions, 31 deletions
diff --git a/114.patch b/114.patch
deleted file mode 100644
index 80daf16..0000000
--- a/114.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 0a8cc92ce6dc1730404e255469082b085b55e84f Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Fri, 13 Sep 2019 14:45:45 +0200
-Subject: [PATCH] Fix Using array_key_exists() on objects is deprecated
-
----
- src/Translator/Loader/Gettext.php | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/Translator/Loader/Gettext.php b/src/Translator/Loader/Gettext.php
-index 2a23d5df..7bef31d2 100644
---- a/src/Translator/Loader/Gettext.php
-+++ b/src/Translator/Loader/Gettext.php
-@@ -139,7 +139,7 @@ public function load($locale, $filename)
- }
-
- // Read header entries
-- if (array_key_exists('', $textDomain)) {
-+ if (isset($textDomain[''])) {
- $rawHeaders = explode("\n", trim($textDomain['']));
-
- foreach ($rawHeaders as $rawHeader) {
diff --git a/composer.json b/composer.json
index 3235805..3597ff0 100644
--- a/composer.json
+++ b/composer.json
@@ -20,7 +20,7 @@
"zendframework/zend-stdlib": "^2.7 || ^3.0"
},
"require-dev": {
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.16",
"zendframework/zend-cache": "^2.6.1",
"zendframework/zend-coding-standard": "~1.0.0",
"zendframework/zend-config": "^2.6",
diff --git a/php-zendframework-zend-i18n.spec b/php-zendframework-zend-i18n.spec
index 1ae31fb..560299a 100644
--- a/php-zendframework-zend-i18n.spec
+++ b/php-zendframework-zend-i18n.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-i18n
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 6d69af5a04e1a4de7250043cb1322f077a0cdb7f
+%global gh_commit 9233ee8553564a6e45e8311a7173734ba4e5db9b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-i18n
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.9.0
-Release: 3%{?dist}
+Version: 2.9.1
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -30,8 +30,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: https://patch-diff.githubusercontent.com/raw/zendframework/zend-i18n/pull/114.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -43,7 +41,7 @@ BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# From composer, "require-dev": {
-# "phpunit/PHPUnit": "^5.7.27 || ^6.5.8 || ^7.1.2",
+# "phpunit/PHPUnit": "^5.7.27 || ^6.5.14 || ^7.5.16",
# "zendframework/zend-cache": "^2.6.1",
# "zendframework/zend-coding-standard": "~1.0.0",
# "zendframework/zend-config": "^2.6",
@@ -100,7 +98,6 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
mv LICENSE.md LICENSE
@@ -160,6 +157,9 @@ exit $ret
%changelog
+* Thu Sep 26 2019 Remi Collet <remi@remirepo.net> - 2.9.1-1
+- update to 2.9.1
+
* Fri Sep 13 2019 Remi Collet <remi@remirepo.net> - 2.9.0-3
- add patch for 7.4 from
https://github.com/zendframework/zend-i18n/pull/114