summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-04-26 15:24:46 +0200
committerRemi Collet <remi@remirepo.net>2018-04-26 15:24:46 +0200
commit01e9c414ab160db6e6fccbfefde1cca9ff68cc3b (patch)
treea8c0b635f43863da05bc11ebaee275c104d631fa
parent1b1c81f7a41badd080c3c4f43216ad7c0f1ee030 (diff)
v2.8.0
-rw-r--r--composer.json46
-rw-r--r--php-zendframework-zend-i18n.spec39
2 files changed, 37 insertions, 48 deletions
diff --git a/composer.json b/composer.json
index c9f6925..b5ff026 100644
--- a/composer.json
+++ b/composer.json
@@ -1,28 +1,26 @@
{
"name": "zendframework/zend-i18n",
- "description": " ",
+ "description": "Provide translations for your application, and filter and validate internationalized values",
"license": "BSD-3-Clause",
"keywords": [
- "zf2",
+ "zendframework",
+ "zf",
"i18n"
],
- "homepage": "https://github.com/zendframework/zend-i18n",
- "extra": {
- "branch-alias": {
- "dev-master": "2.7-dev",
- "dev-develop": "2.8-dev"
- },
- "zf": {
- "component": "Zend\\I18n",
- "config-provider": "Zend\\I18n\\ConfigProvider"
- }
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-i18n/",
+ "issues": "https://github.com/zendframework/zend-i18n/issues",
+ "source": "https://github.com/zendframework/zend-i18n",
+ "rss": "https://github.com/zendframework/zend-i18n/releases.atom",
+ "chat": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
},
"require": {
- "php": "^7.0 || ^5.6",
+ "php": "^5.6 || ^7.0",
"zendframework/zend-stdlib": "^2.7 || ^3.0"
},
"require-dev": {
- "phpunit/PHPUnit": "^6.0.8 || ^5.7.15",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
"zendframework/zend-cache": "^2.6.1",
"zendframework/zend-coding-standard": "~1.0.0",
"zendframework/zend-config": "^2.6",
@@ -38,10 +36,10 @@
"zendframework/zend-config": "Zend\\Config component",
"zendframework/zend-eventmanager": "You should install this package to use the events in the translator",
"zendframework/zend-filter": "You should install this package to use the provided filters",
+ "zendframework/zend-i18n-resources": "Translation resources",
"zendframework/zend-servicemanager": "Zend\\ServiceManager component",
"zendframework/zend-validator": "You should install this package to use the provided validators",
- "zendframework/zend-view": "You should install this package to use the provided view helpers",
- "zendframework/zend-i18n-resources": "Translation resources"
+ "zendframework/zend-view": "You should install this package to use the provided view helpers"
},
"autoload": {
"psr-4": {
@@ -53,6 +51,19 @@
"ZendTest\\I18n\\": "test/"
}
},
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.8.x-dev",
+ "dev-develop": "2.9.x-dev"
+ },
+ "zf": {
+ "component": "Zend\\I18n",
+ "config-provider": "Zend\\I18n\\ConfigProvider"
+ }
+ },
"scripts": {
"check": [
"@cs-check",
@@ -61,7 +72,6 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
- "upload-coverage": "coveralls -v"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
}
diff --git a/php-zendframework-zend-i18n.spec b/php-zendframework-zend-i18n.spec
index 0b275e8..bf0d7e0 100644
--- a/php-zendframework-zend-i18n.spec
+++ b/php-zendframework-zend-i18n.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit d3431e29cc00c2a1c6704e601d4371dbf24f6a31
+%global gh_commit cfdb658121e0d7eb969a498c2f67f1eacaab9c63
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-i18n
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.4
+Version: 2.8.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -41,7 +41,7 @@ BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# From composer, "require-dev": {
-# "phpunit/PHPUnit": "^6.0.8 || ^5.7.15",
+# "phpunit/PHPUnit": "^5.7.27 || ^6.5.8 || ^7.1.2",
# "zendframework/zend-cache": "^2.6.1",
# "zendframework/zend-coding-standard": "~1.0.0",
# "zendframework/zend-config": "^2.6",
@@ -57,43 +57,19 @@ BuildRequires: php-composer(%{gh_owner}/zend-filter) >= 2.5
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-view) >= 2.6.3
-%if 0%{?fedora} >= 26
-%global phpunit %{_bindir}/phpunit6
-%else
%global phpunit %{_bindir}/phpunit
-%endif
-BuildRequires: %{phpunit}
+BuildRequires: phpunit >= 5.7.27
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": "^7.0 || ^5.6",
+# "php": "^5.6 || ^7.0",
# "zendframework/zend-stdlib": "^2.7 || ^3.0"
Requires: php(language) >= 5.6
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
-# From composer, "suggest": {
-# "ext-intl": "Required for most features of Zend\\I18n; included in default builds of PHP",
-# "zendframework/zend-cache": "Zend\\Cache component",
-# "zendframework/zend-config": "Zend\\Config component",
-# "zendframework/zend-eventmanager": "You should install this package to use the events in the translator",
-# "zendframework/zend-filter": "You should install this package to use the provided filters",
-# "zendframework/zend-servicemanager": "Zend\\ServiceManager component",
-# "zendframework/zend-validator": "You should install this package to use the provided validators",
-# "zendframework/zend-view": "You should install this package to use the provided view helpers",
-# "zendframework/zend-resources": "Translation resources"
-%if 0%{?fedora} >= 21
-Suggests: php-composer(%{gh_owner}/zend-cache)
-Suggests: php-composer(%{gh_owner}/zend-config)
-Suggests: php-composer(%{gh_owner}/zend-eventmanager)
-Suggests: php-composer(%{gh_owner}/zend-filter)
-Suggests: php-composer(%{gh_owner}/zend-servicemanager)
-Suggests: php-composer(%{gh_owner}/zend-validator)
-Suggests: php-composer(%{gh_owner}/zend-view)
-Suggests: php-composer(%{gh_owner}/zend-i18n-resources)
-%endif
%endif
Requires: php-intl
# From phpcompatinfo report for version 2.5.1
@@ -156,7 +132,7 @@ require_once '%{php_home}/Zend/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" php70 php71 php72; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
@@ -177,6 +153,9 @@ exit $ret
%changelog
+* Thu Apr 26 2018 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- update to 2.8.0
+
* Mon May 22 2017 Remi Collet <remi@remirepo.net> - 2.7.4-1
- Update to 2.7.4
- raise dependency on PHP 5.6