summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile3
-rwxr-xr-xmakesrc.sh27
-rw-r--r--php-zendframework-zend-i18n-resources.spec116
3 files changed, 146 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..a2cd659
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,3 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..24fbf81
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,27 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-zendframework-zend-i18n-resources.spec b/php-zendframework-zend-i18n-resources.spec
new file mode 100644
index 0000000..86b5178
--- /dev/null
+++ b/php-zendframework-zend-i18n-resources.spec
@@ -0,0 +1,116 @@
+# remirepo spec/Fedora file for php-zendframework-zend-i18n-resources
+#
+# Copyright (c) 2015 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit 7313a7711d283ade0fccce162b49c6ee62b02763
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zend-i18n-resources
+%global php_home %{_datadir}/php
+%global library Translator
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 2.5.1
+Release: 1%{?dist}
+Summary: Zend Framework %{library} component
+
+Group: Development/Libraries
+License: BSD
+URL: http://framework.zend.com/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.5
+BuildRequires: php-cli
+BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
+%endif
+
+# From composer, "require": {
+# "php": ">=5.5"
+Requires: php(language) >= 5.5
+# From phpcompatinfo report for version 2.5.1
+# None
+
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+This "component" provides translation resources, specifically
+for zendframework/zend-validate and zendframework/zend-captcha,
+for use with zendframework/zend-i18n's Translator subcomponent.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+# Empty build section, nothing required
+
+
+%install
+rm -rf %{buildroot}
+
+mkdir -p %{buildroot}%{php_home}/Zend/I18n
+cp -pr src %{buildroot}%{php_home}/Zend/I18n/%{library}
+cp -pr languages %{buildroot}%{php_home}/Zend/I18n/languages
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << EOF | tee vendor/autoload.php
+<?php
+require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
+Zend\\Loader\\AutoloaderFactory::factory(array(
+ 'Zend\\Loader\\StandardAutoloader' => array(
+ 'namespaces' => array(
+ 'Zend\\\\I18n' => '%{buildroot}%{php_home}/Zend/I18n'
+))));
+require_once '%{php_home}/Zend/autoload.php';
+EOF
+php -r '
+ require "vendor/autoload.php";
+ use Zend\I18n\Translator\Resources;
+ $fic = Resources::getBasePath().sprintf(Resources::getPatternForCaptcha(), "fr");
+ echo realpath($fic)."\n";
+ exit (file_exists($fic) ? 0 : 1);
+'
+%else
+: Test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE.txt
+%doc CONTRIBUTING.md README.md
+%doc composer.json
+%dir %{php_home}/Zend/
+%dir %{php_home}/Zend/I18n
+ %{php_home}/Zend/I18n/%{library}
+ %{php_home}/Zend/I18n/languages
+
+
+%changelog
+* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
+- initial package \ No newline at end of file