summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-hydrator.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-hydrator.spec')
-rw-r--r--php-zendframework-zend-hydrator.spec46
1 files changed, 24 insertions, 22 deletions
diff --git a/php-zendframework-zend-hydrator.spec b/php-zendframework-zend-hydrator.spec
index aca753f..90f81f6 100644
--- a/php-zendframework-zend-hydrator.spec
+++ b/php-zendframework-zend-hydrator.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 0ac0d3e569781f1895670b0c8d0dc7f25b8a3182
+%global gh_commit e3ecc4920c1724e1949213163fee82200e8e6f6c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-hydrator
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.2.1
+Version: 2.2.2
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -34,7 +34,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
BuildRequires: php-date
BuildRequires: php-reflection
BuildRequires: php-spl
@@ -45,22 +45,27 @@ BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 3.0
# "zendframework/zend-serializer": "^2.6.1",
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
# "zendframework/zend-filter": "^2.6",
-# "phpunit/phpunit": "^4.5",
-# "squizlabs/php_codesniffer": "^2.3.1"
+# "phpunit/phpunit": "^6.0.10 || ^5.7.17",
+# "zendframework/zend-coding-standard": "~1.0.0"
BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6.2
BuildRequires: php-composer(%{gh_owner}/zend-inputfilter) >= 2.5
BuildRequires: php-composer(%{gh_owner}/zend-serializer) >= 2.6.1
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
BuildRequires: php-composer(%{gh_owner}/zend-filter) >= 2.6
-BuildRequires: php-composer(phpunit/phpunit) >= 4.5
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": "^5.5 || ^7.0",
+# "php": "^7.0 || ^5.6",
# "zendframework/zend-stdlib": "^3.0"
-Requires: php(language) >= 5.5
+Requires: php(language) >= 5.6
Requires: php-composer(%{gh_owner}/zend-stdlib) >= 3.0
Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
# From composer, "suggest": {
@@ -125,21 +130,13 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
- run=1
-fi
-if which php71; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home} --verbose
-# remirepo:2
-fi
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit6} -d memory_limit=1G || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
@@ -160,6 +157,11 @@ rm -rf %{buildroot}
%changelog
+* Mon May 22 2017 Remi Collet <remi@remirepo.net> - 2.2.2-1
+- Update to 2.2.2
+- raise dependency on PHP 5.6
+- use phpunit6 on F26+
+
* Wed Jun 29 2016 Remi Collet <remi@fedoraproject.org> - 2.2.1-1
- update to 2.2.1 for ZendFramework 3
- raise dependency on zend-stdlib >= 3.0