summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-zendframework-zend-hydrator.spec60
1 files changed, 37 insertions, 23 deletions
diff --git a/php-zendframework-zend-hydrator.spec b/php-zendframework-zend-hydrator.spec
index c077328..370ca61 100644
--- a/php-zendframework-zend-hydrator.spec
+++ b/php-zendframework-zend-hydrator.spec
@@ -37,7 +37,7 @@ BuildRequires: php(language) >= 5.6
BuildRequires: php-date
BuildRequires: php-reflection
BuildRequires: php-spl
-BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 3.0
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.0
# From composer, "require-dev": {
# "zendframework/zend-eventmanager": "^3.0",
# "zendframework/zend-inputfilter": "^2.6",
@@ -46,38 +46,40 @@ BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 3.0
# "zendframework/zend-filter": "^2.6",
# "phpunit/phpunit": "^5.7.21 || ^6.3",
# "zendframework/zend-coding-standard": "~1.0.0"
-BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6.2
-BuildRequires: php-composer(%{gh_owner}/zend-inputfilter) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-serializer) >= 2.6.1
-BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
-BuildRequires: php-composer(%{gh_owner}/zend-filter) >= 2.6
+BuildRequires: php-autoloader(%{gh_owner}/zend-eventmanager) >= 2.6.2
+BuildRequires: php-autoloader(%{gh_owner}/zend-inputfilter) >= 2.5
+BuildRequires: php-autoloader(%{gh_owner}/zend-serializer) >= 2.6.1
+BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
+BuildRequires: php-autoloader(%{gh_owner}/zend-filter) >= 2.6
%if 0%{?fedora} >= 26
%global phpunit %{_bindir}/phpunit6
%else
%global phpunit %{_bindir}/phpunit
%endif
BuildRequires: %{phpunit}
-# Autoloader
-BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^5.6 || ^7.0",
# "zendframework/zend-stdlib": "^3.0"
Requires: php(language) >= 5.6
-Requires: php-composer(%{gh_owner}/zend-stdlib) >= 3.0
-Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.0
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
# From composer, "suggest": {
# "zendframework/zend-eventmanager": "^2.6.2 || ^3.0, to support aggregate hydrator usage",
# "zendframework/zend-serializer": "^2.6.1, to use the SerializableStrategy",
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3, to support hydrator plugin manager usage",
# "zendframework/zend-filter": "^2.6, to support naming strategy hydrator usage"
%if 0%{?fedora} >= 21
-Suggests: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6.2
-Suggests: php-composer(%{gh_owner}/zend-serializer) >= 2.6.1
-Suggests: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
-Suggests: php-composer(%{gh_owner}/zend-filter) >= 2.6
+Suggests: php-autoloader(%{gh_owner}/zend-eventmanager) >= 2.6.2
+Suggests: php-autoloader(%{gh_owner}/zend-serializer) >= 2.6.1
+Suggests: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
+Suggests: php-autoloader(%{gh_owner}/zend-filter) >= 2.6
%endif
+# Autoloader
+Requires: php-composer(fedora/autoloader)
# From phpcompatinfo report for version 1.1.0
Requires: php-date
Requires: php-reflection
@@ -86,6 +88,7 @@ Requires: php-spl
Requires: php-composer(%{gh_owner}/zend-loader) >= 2.5
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
%description
@@ -104,7 +107,18 @@ mv LICENSE.md LICENSE
%build
-# Empty build section, nothing required
+phpab --template fedora --output src/autoload.php src
+cat << 'EOF' | tee -a src/autoload.php
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Zend/Stdlib/autoload.php',
+]);
+\Fedora\Autoloader\Dependencies::optional([
+ '%{php_home}/Zend/EventManager/autoload.php',
+ '%{php_home}/Zend/Serializer/autoload.php',
+ '%{php_home}/Zend/ServiceManager/autoload.php',
+ '%{php_home}/Zend/Filter/autoload.php',
+]);
+EOF
%install
@@ -117,14 +131,11 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
-require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
-Zend\Loader\AutoloaderFactory::factory(array(
- 'Zend\Loader\StandardAutoloader' => array(
- 'namespaces' => array(
- 'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
- 'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
-))));
-require_once '%{php_home}/Zend/autoload.php';
+require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Zend/InputFilter/autoload.php',
+]);
+\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
EOF
ret=0
@@ -149,6 +160,9 @@ exit $ret
%changelog
+* Thu Dec 7 2017 Remi Collet <remi@remirepo.net> - 2.3.1-2
+- switch from zend-loader to fedora/autoloader
+
* Tue Oct 3 2017 Remi Collet <remi@remirepo.net> - 2.3.1-1
- Update to 2.3.1