summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-http.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-02 07:33:58 +0100
committerRemi Collet <remi@remirepo.net>2017-11-02 07:33:58 +0100
commited00d884f6b1541aeaed7fd7661e469dc9acaaa0 (patch)
tree1dfed578ed63ab14f2d1b5fca4e69ee6918a7375 /php-zendframework-zend-http.spec
parentf7fbe2a1c9ce53233afdad5d65d788839b2683c4 (diff)
Update to 2.7.0
use phpunit6 on F26+ raise dependency on PHP 5.6 raise dependency on zendframework/zend-loader 2.5.1 raise dependency on zendframework/zend-stdlib 2.7.7 raise dependency on zendframework/zend-uri 2.5.2 raise dependency on zendframework/zend-validator 2.10.1
Diffstat (limited to 'php-zendframework-zend-http.spec')
-rw-r--r--php-zendframework-zend-http.spec73
1 files changed, 39 insertions, 34 deletions
diff --git a/php-zendframework-zend-http.spec b/php-zendframework-zend-http.spec
index d8dd991..4a9c537 100644
--- a/php-zendframework-zend-http.spec
+++ b/php-zendframework-zend-http.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 09f4d279f46d86be63171ff62ee0f79eca878678
+%global gh_commit 78aa510c0ea64bfb2aa234f50c4f232c9531acfa
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-http
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.6.0
+Version: 2.7.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -34,7 +34,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
BuildRequires: php-ctype
BuildRequires: php-curl
BuildRequires: php-date
@@ -43,35 +43,39 @@ BuildRequires: php-openssl
BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-zlib
-BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-uri) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5.1
+BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7.7
+BuildRequires: php-composer(%{gh_owner}/zend-uri) >= 2.5.2
+BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.10.1
# From composer, "require-dev": {
-# "phpunit/PHPUnit": "~4.0",
-# "zendframework/zend-config": "^2.5",
-# "zendframework/zend-coding-standard": "~1.0.0"
+# "phpunit/phpunit": "^6.4.1 || ^5.7.15",
+# "zendframework/zend-coding-standard": "~1.0.0",
+# "zendframework/zend-config": "^3.1 || ^2.6"
BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.5
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": "^5.5 || ^7.0",
-# "zendframework/zend-loader": "~2.5",
-# "zendframework/zend-stdlib": "^2.5 || ^3.0",
-# "zendframework/zend-uri": "~2.5",
-# "zendframework/zend-validator": "~2.5"
-Requires: php(language) >= 5.5
+# "php": "^5.6 || ^7.0",
+# "zendframework/zend-loader": "^2.5.1",
+# "zendframework/zend-stdlib": "^3.1 || ^2.7.7",
+# "zendframework/zend-uri": "^2.5.2",
+# "zendframework/zend-validator": "^2.10.1"
+Requires: php(language) >= 5.6
%if ! %{bootstrap}
-Requires: php-composer(%{gh_owner}/zend-loader) >= 2.5
+Requires: php-composer(%{gh_owner}/zend-loader) >= 2.5.1
Requires: php-composer(%{gh_owner}/zend-loader) < 3
-Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
+Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7.7
Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
Requires: php-composer(%{gh_owner}/zend-uri) >= 2.5
Requires: php-composer(%{gh_owner}/zend-uri) < 3
-Requires: php-composer(%{gh_owner}/zend-validator) >= 2.5
+Requires: php-composer(%{gh_owner}/zend-validator) >= 2.10.1
Requires: php-composer(%{gh_owner}/zend-validator) < 3
%endif
# From phpcompatinfo report for version 2.5.1
@@ -130,21 +134,13 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-# remirepo:11
ret=0
-run=0
-if which php56; then
- php56 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose
-# remirepo:2
-fi
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit6} || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
@@ -165,6 +161,15 @@ rm -rf %{buildroot}
%changelog
+* Thu Nov 2 2017 Remi Collet <remi@remirepo.net> - 2.7.0-1
+- Update to 2.7.0
+- use phpunit6 on F26+
+- raise dependency on PHP 5.6
+- raise dependency on zendframework/zend-loader 2.5.1
+- raise dependency on zendframework/zend-stdlib 2.7.7
+- raise dependency on zendframework/zend-uri 2.5.2
+- raise dependency on zendframework/zend-validator 2.10.1
+
* Wed Feb 1 2017 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
- version 2.6.0