summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-04-27 08:06:15 +0200
committerRemi Collet <remi@remirepo.net>2018-04-27 08:06:15 +0200
commit973b5e23af0ea1745239b2965c23fb2561c9b1e3 (patch)
treec11cf8e766427d00af8ee89e262f426361d55a37
parent96c91a164c04ce6c5c118ceb75790608b0779ffe (diff)
v2.8.0
-rw-r--r--composer.json25
-rw-r--r--php-zendframework-zend-http.spec20
2 files changed, 23 insertions, 22 deletions
diff --git a/composer.json b/composer.json
index f37a9b1..07e1d89 100644
--- a/composer.json
+++ b/composer.json
@@ -1,7 +1,6 @@
{
"name": "zendframework/zend-http",
- "description": "provides an easy interface for performing Hyper-Text Transfer Protocol (HTTP) requests",
- "homepage": "https://github.com/zendframework/zend-http",
+ "description": "Provides an easy interface for performing Hyper-Text Transfer Protocol (HTTP) requests",
"license": "BSD-3-Clause",
"keywords": [
"zf",
@@ -11,16 +10,13 @@
"HTTP client"
],
"support": {
- "docs": "https://docs.zendframework.com/zend-http",
+ "docs": "https://docs.zendframework.com/zend-http/",
"issues": "https://github.com/zendframework/zend-http/issues",
"source": "https://github.com/zendframework/zend-http",
"rss": "https://github.com/zendframework/zend-http/releases.atom",
- "slack": "https://zendframework-slack.herokuapp.com",
+ "chat": "https://zendframework-slack.herokuapp.com",
"forum": "https://discourse.zendframework.com/c/questions/components"
},
- "config": {
- "sort-packages": true
- },
"require": {
"php": "^5.6 || ^7.0",
"zendframework/zend-loader": "^2.5.1",
@@ -29,10 +25,13 @@
"zendframework/zend-validator": "^2.10.1"
},
"require-dev": {
- "phpunit/phpunit": "^6.4.1 || ^5.7.15",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.3",
"zendframework/zend-coding-standard": "~1.0.0",
"zendframework/zend-config": "^3.1 || ^2.6"
},
+ "suggest": {
+ "paragonie/certainty": "For automated management of cacert.pem"
+ },
"autoload": {
"psr-4": {
"Zend\\Http\\": "src/"
@@ -43,10 +42,13 @@
"ZendTest\\Http\\": "test/"
}
},
+ "config": {
+ "sort-packages": true
+ },
"extra": {
"branch-alias": {
- "dev-master": "2.7-dev",
- "dev-develop": "2.8-dev"
+ "dev-master": "2.8.x-dev",
+ "dev-develop": "2.9.x-dev"
}
},
"scripts": {
@@ -57,7 +59,6 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
- "upload-coverage": "coveralls -v"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
}
diff --git a/php-zendframework-zend-http.spec b/php-zendframework-zend-http.spec
index c825208..2916479 100644
--- a/php-zendframework-zend-http.spec
+++ b/php-zendframework-zend-http.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-http
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 78aa510c0ea64bfb2aa234f50c4f232c9531acfa
+%global gh_commit f48b276ffa11b48dd1ae3c6bc306d6ed7958ef51
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-http
@@ -20,11 +20,10 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.0
+Version: 2.8.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
-Group: Development/Libraries
License: BSD
URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
@@ -47,15 +46,13 @@ BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7.7
BuildRequires: php-composer(%{gh_owner}/zend-uri) >= 2.5.2
BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.10.1
# From composer, "require-dev": {
-# "phpunit/phpunit": "^6.4.1 || ^5.7.15",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.3",
# "zendframework/zend-coding-standard": "~1.0.0",
# "zendframework/zend-config": "^3.1 || ^2.6"
BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.5
-%if 0%{?fedora} >= 26
-%global phpunit %{_bindir}/phpunit6
-%else
%global phpunit %{_bindir}/phpunit
-%endif
+BuildRequires: php-composer(phpunit/phpunit) >= 5.7.27
+
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
@@ -132,7 +129,7 @@ require_once '%{php_home}/Zend/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" php70 php71 php72; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit6} || ret=1
@@ -153,6 +150,9 @@ exit $ret
%changelog
+* Fri Apr 27 2018 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- update to 2.8.0
+
* Thu Nov 2 2017 Remi Collet <remi@remirepo.net> - 2.7.0-1
- Update to 2.7.0
- use phpunit6 on F26+