summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json9
-rw-r--r--php-zendframework-zend-form.spec61
2 files changed, 55 insertions, 15 deletions
diff --git a/composer.json b/composer.json
index a4470fd..ee89f26 100644
--- a/composer.json
+++ b/composer.json
@@ -18,7 +18,7 @@
"require": {
"php": "^5.6 || ^7.0",
"zendframework/zend-inputfilter": "^2.8",
- "zendframework/zend-hydrator": "^1.1 || ^2.1",
+ "zendframework/zend-hydrator": "^1.1 || ^2.1 || ^3.0",
"zendframework/zend-stdlib": "^2.7 || ^3.0"
},
"require-dev": {
@@ -57,6 +57,9 @@
]
},
"autoload-dev": {
+ "files": [
+ "test/_autoload.php"
+ ],
"psr-4": {
"ZendTest\\Form\\": "test/"
}
@@ -66,8 +69,8 @@
},
"extra": {
"branch-alias": {
- "dev-master": "2.12.x-dev",
- "dev-develop": "2.13.x-dev"
+ "dev-master": "2.13.x-dev",
+ "dev-develop": "2.14.x-dev"
},
"zf": {
"component": "Zend\\Form",
diff --git a/php-zendframework-zend-form.spec b/php-zendframework-zend-form.spec
index 6bca6f2..395388d 100644
--- a/php-zendframework-zend-form.spec
+++ b/php-zendframework-zend-form.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 565fb4f4bb3e0dbeea0173c923c4a8be77de9441
+%global gh_commit c713a12ccbd43148b71c9339e171ca11e3f8a1da
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-form
@@ -19,10 +19,8 @@
%global with_tests 0%{!?_without_tests:1}
%endif
-# TODO: re-enable phpunit6 when 6.5 will be available
-
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.12.0
+Version: 2.13.0
Release: 2%{?dist}
Summary: Zend Framework %{library} component
@@ -42,9 +40,17 @@ BuildRequires: php-pcre
BuildRequires: php-spl
# Temporary, see https://github.com/zendframework/zend-math/issues/23
BuildRequires: php-mcrypt
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-autoloader(%{gh_owner}/zend-inputfilter) >= 2.8 with php-autoloader(%{gh_owner}/zend-inputfilter) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-hydrator) >= 1.1 with php-autoloader(%{gh_owner}/zend-hydrator) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+# remirepo:5
+%else
BuildRequires: php-autoloader(%{gh_owner}/zend-inputfilter) >= 2.8
BuildRequires: php-autoloader(%{gh_owner}/zend-hydrator) >= 1.0
BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
+%endif
# From composer, "require-dev": {
# "doctrine/annotations": "~1.0",
# "zendframework/zend-cache": "^2.6.1",
@@ -62,6 +68,25 @@ BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
# "zendframework/zendservice-recaptcha": "^3.0.0",
# "phpunit/phpunit": "^5.7.23 || ^6.5.3",
# "zendframework/zend-coding-standard": "~1.0.0"
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(doctrine/annotations) >= 1.0 with php-composer(doctrine/annotations) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-cache) >= 2.6.1 with php-autoloader(%{gh_owner}/zend-cache) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-captcha) >= 2.7.1 with php-autoloader(%{gh_owner}/zend-captcha) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-code) >= 2.6 with php-autoloader(%{gh_owner}/zend-code) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-escaper) >= 2.5 with php-autoloader(%{gh_owner}/zend-escaper) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-eventmanager) >= 2.6.2 with php-autoloader(%{gh_owner}/zend-eventmanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-filter) >= 2.6 with php-autoloader(%{gh_owner}/zend-filter) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-i18n) >= 2.6 with php-autoloader(%{gh_owner}/zend-i18n) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-session) >= 2.8.1 with php-autoloader(%{gh_owner}/zend-session) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-text) >= 2.6 with php-autoloader(%{gh_owner}/zend-text) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.6 with php-autoloader(%{gh_owner}/zend-validator) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-view) >= 2.6.2 with php-autoloader(%{gh_owner}/zend-view) < 3)
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.5.3
+# remirepo:17
+%else
BuildRequires: php-composer(doctrine/annotations) >= 1.0
BuildRequires: php-autoloader(%{gh_owner}/zend-cache) >= 2.6.1
BuildRequires: php-autoloader(%{gh_owner}/zend-captcha) >= 2.7.1
@@ -75,10 +100,6 @@ BuildRequires: php-autoloader(%{gh_owner}/zend-session) >= 2.8.1
BuildRequires: php-autoloader(%{gh_owner}/zend-text) >= 2.6
BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.6
BuildRequires: php-autoloader(%{gh_owner}/zend-view) >= 2.6.2
-%if 0
-%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6 >= 6.5.3
-%else
%global phpunit %{_bindir}/phpunit
BuildRequires: php-phpunit-PHPUnit >= 5.7.23
%endif
@@ -91,10 +112,19 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^5.6 || ^7.0",
# "zendframework/zend-inputfilter": "^2.8",
-# "zendframework/zend-hydrator": "^1.1 || ^2.1",
+# "zendframework/zend-hydrator": "^1.1 || ^2.1 || ^3.0",
# "zendframework/zend-stdlib": "^2.7 || ^3.0"
Requires: php(language) >= 5.6
%if ! %{bootstrap}
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-autoloader(%{gh_owner}/zend-inputfilter) >= 2.8 with php-autoloader(%{gh_owner}/zend-inputfilter) < 3)
+Requires: (php-autoloader(%{gh_owner}/zend-hydrator) >= 1.1 with php-autoloader(%{gh_owner}/zend-hydrator) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+# Mandory because of Polyfill
+Requires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
+# remirepo:11
+%else
Requires: php-autoloader(%{gh_owner}/zend-inputfilter) >= 2.8
Requires: php-autoloader(%{gh_owner}/zend-inputfilter) < 3
Requires: php-autoloader(%{gh_owner}/zend-hydrator) >= 1.1
@@ -104,6 +134,7 @@ Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
# Mandory because of Polyfill
Requires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
Requires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
+%endif
# From composer, "suggest": {
# "zendframework/zend-captcha": "^2.7.1, required for using CAPTCHA form elements",
# "zendframework/zend-code": "^2.6 || ^3.0, required to use zend-form annotations support",
@@ -112,7 +143,7 @@ Requires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3, required to use the form factories or provide services",
# "zendframework/zend-view": "^2.6.2, required for using the zend-form view helpers",
# "zendframework/zendservice-recaptcha": "in order to use the ReCaptcha form element"
-%if 0%{?fedora} >= 21
+%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
Suggests: php-autoloader(%{gh_owner}/zend-captcha)
Suggests: php-autoloader(%{gh_owner}/zend-code)
Suggests: php-autoloader(%{gh_owner}/zend-eventmanager)
@@ -189,7 +220,9 @@ mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
\Fedora\Autoloader\Dependencies::required([
+ dirname(__DIR__) . '/test/_autoload.php',
'%{php_home}/Zend/Cache/autoload.php',
'%{php_home}/Zend/Escaper/autoload.php',
'%{php_home}/Zend/Filter/autoload.php',
@@ -197,11 +230,10 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
'%{php_home}/Zend/Text/autoload.php',
'%{php_home}/Zend/Validator/autoload.php',
]);
-\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
EOF
ret=0
-for cmdarg in "php %{phpunit}" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" php70 php71 php72 php73; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit6} -d memory_limit=1G || ret=1
@@ -223,6 +255,11 @@ exit $ret
%changelog
+* Wed Dec 12 2018 Remi Collet <remi@remirepo.net> - 2.13.0-1
+- update to 2.13.0
+- allow zend-hydrator 3
+- use range dependencies
+
* Wed May 23 2018 Remi Collet <remi@remirepo.net> - 2.12.0-2
- update to 2.12.0