summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--235.patch22
-rw-r--r--composer.json2
-rw-r--r--php-zendframework-zend-form.spec14
3 files changed, 34 insertions, 4 deletions
diff --git a/235.patch b/235.patch
new file mode 100644
index 0000000..1926da6
--- /dev/null
+++ b/235.patch
@@ -0,0 +1,22 @@
+From 19d1ed9c335a1d9ea1ccf718f420444acb4ec277 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Fri, 4 Oct 2019 09:30:17 +0200
+Subject: [PATCH] fix Trying to access array offset on value of type null (7.4)
+
+---
+ src/Form.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Form.php b/src/Form.php
+index 035cd85b..3ee441c2 100644
+--- a/src/Form.php
++++ b/src/Form.php
+@@ -364,7 +364,7 @@ public function bindValues(array $values = [], array $validationGroup = null)
+ $data = array_key_exists($this->baseFieldset->getName(), $data)
+ ? $data[$this->baseFieldset->getName()]
+ : [];
+- $this->object = $this->baseFieldset->bindValues($data, $validationGroup[$this->baseFieldset->getName()]);
++ $this->object = $this->baseFieldset->bindValues($data, $validationGroup ? $validationGroup[$this->baseFieldset->getName()] : null);
+ } else {
+ $this->object = parent::bindValues($data, $validationGroup);
+ }
diff --git a/composer.json b/composer.json
index 8d29eb2..ec29a50 100644
--- a/composer.json
+++ b/composer.json
@@ -12,7 +12,7 @@
"issues": "https://github.com/zendframework/zend-form/issues",
"source": "https://github.com/zendframework/zend-form",
"rss": "https://github.com/zendframework/zend-form/releases.atom",
- "slack": "https://zendframework-slack.herokuapp.com",
+ "chat": "https://zendframework-slack.herokuapp.com",
"forum": "https://discourse.zendframework.com/c/questions/components"
},
"require": {
diff --git a/php-zendframework-zend-form.spec b/php-zendframework-zend-form.spec
index 189f2a8..50ca144 100644
--- a/php-zendframework-zend-form.spec
+++ b/php-zendframework-zend-form.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit ff9385b7d0d93d9bdbc2aa4af82ab616dbc7d4be
+%global gh_commit 284f51cf26af2d3d88936fd8b74d46853550b718*
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-form
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.14.1
+Version: 2.14.2
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -29,6 +29,8 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
+Patch0: https://patch-diff.githubusercontent.com/raw/zendframework/zend-form/pull/235.patch
+
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -176,6 +178,7 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
mv LICENSE.md LICENSE
@@ -232,7 +235,7 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" php70 php71 php72 php73; do
+for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit6} -d memory_limit=1G || ret=1
@@ -254,6 +257,11 @@ exit $ret
%changelog
+* Fri Oct 4 2019 Remi Collet <remi@remirepo.net> - 2.14.2-1
+- update to 2.14.2
+- add patch for PHP 7.4 from
+ https://github.com/zendframework/zend-form/pull/235
+
* Wed Feb 27 2019 Remi Collet <remi@remirepo.net> - 2.14.1-1
- update to 2.14.1