summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-09-10 06:30:35 +0200
committerRemi Collet <fedora@famillecollet.com>2015-09-10 06:30:35 +0200
commit5011da5a7ba26794331235c6ce86d9eeb71c2735 (patch)
tree4ab42812727e168a4daa22c0a85dd7169a995f30
parentcfe42b1eb9617f7c041bf59322d6c5dafd793a40 (diff)
php-zendframework-zend-form: 2.5.2
-rw-r--r--php-zendframework-zend-form.spec22
1 files changed, 13 insertions, 9 deletions
diff --git a/php-zendframework-zend-form.spec b/php-zendframework-zend-form.spec
index db2211c..b1626ef 100644
--- a/php-zendframework-zend-form.spec
+++ b/php-zendframework-zend-form.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit a3b9151013e419e4401f66726746abdba174ed21
+%global gh_commit 576ef1010c36f657135ada7b124220f4cf0f56bf
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-form
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.1
+Version: 2.5.2
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -81,10 +81,10 @@ BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": ">=5.3.23",
+# "php": ">=5.5",
# "zendframework/zend-inputfilter": "~2.5",
# "zendframework/zend-stdlib": "~2.5"
-Requires: php(language) >= 5.3.23
+Requires: php(language) >= 5.5
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-inputfilter) >= 2.5
Requires: php-composer(%{gh_owner}/zend-inputfilter) < 3
@@ -148,14 +148,14 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
%check
%if %{with_tests}
mkdir vendor
-cat << EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
-Zend\\Loader\\AutoloaderFactory::factory(array(
- 'Zend\\Loader\\StandardAutoloader' => array(
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
'namespaces' => array(
- 'ZendTest\\\\%{library}' => dirname(__DIR__).'/test/',
- 'Zend\\\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
+ 'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
+ 'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
@@ -179,5 +179,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Sep 10 2015 Remi Collet <remi@fedoraproject.org> - 2.5.2-1
+- update to 2.5.2
+- raise minimum php version to 5.5
+
* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
- initial package \ No newline at end of file