summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-05-22 08:50:18 +0200
committerRemi Collet <remi@remirepo.net>2017-05-22 08:50:18 +0200
commit7d5f2689e491124d540b82c2926c1f337bea94a7 (patch)
tree07a3bcdcc5699db87f1d414909b887c2047f64f9
parent3b10ae05c4075e9bff7b2a088eefefa5437eac77 (diff)
v2.7.2
-rw-r--r--.gitignore7
-rw-r--r--composer.json17
-rw-r--r--php-zendframework-zend-filter.spec59
3 files changed, 48 insertions, 35 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index b7e2859..e2e1405 100644
--- a/composer.json
+++ b/composer.json
@@ -18,11 +18,11 @@
},
"require-dev": {
"pear/archive_tar": "^1.4",
- "zendframework/zend-crypt": "^2.6",
+ "zendframework/zend-crypt": "^2.6 || ^3.0",
"zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
"zendframework/zend-uri": "^2.5",
- "fabpot/php-cs-fixer": "1.7.*",
- "phpunit/PHPUnit": "~4.0"
+ "phpunit/PHPUnit": "^6.0.10 || ^5.7.17",
+ "zendframework/zend-coding-standard": "~1.0.0"
},
"suggest": {
"zendframework/zend-crypt": "Zend\\Crypt component, for encryption filters",
@@ -46,5 +46,16 @@
"psr-4": {
"ZendTest\\Filter\\": "test/"
}
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
+ "upload-coverage": "coveralls -v"
}
}
diff --git a/php-zendframework-zend-filter.spec b/php-zendframework-zend-filter.spec
index b33d08d..75f898c 100644
--- a/php-zendframework-zend-filter.spec
+++ b/php-zendframework-zend-filter.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 84c50246428efb0a1e52868e162dab3e149d5b80
+%global gh_commit b8d0ff872f126631bf63a932e33aa2d22d467175
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-filter
@@ -21,8 +21,8 @@
%global php_version %(php -r 'echo PHP_VERSION;')
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.1
-Release: 3%{?dist}
+Version: 2.7.2
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -46,16 +46,21 @@ BuildRequires: php-zip
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# From composer, "require-dev": {
# "pear/archive_tar": "^1.4",
-# "zendframework/zend-crypt": "^2.6",
+# "zendframework/zend-crypt": "^2.6 || ^3.0",
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
# "zendframework/zend-uri": "^2.5",
-# "fabpot/php-cs-fixer": "1.7.*",
-# "phpunit/PHPUnit": "~4.0"
+# "phpunit/PHPUnit": "^6.0.10 || ^5.7.17",
+# "zendframework/zend-coding-standard": "~1.0.0"
BuildRequires: php-composer(pear/archive_tar) >= 1.4
BuildRequires: php-composer(%{gh_owner}/zend-crypt) >= 2.5
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.5
BuildRequires: php-composer(%{gh_owner}/zend-uri) >= 2.5
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
@@ -132,32 +137,18 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-# remirepo:18
-run=0
+# PHP 7.2: idn_to_ascii(): INTL_IDNA_VARIANT_2003 is deprecated
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if which php70; then
- php70 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if which php71; then
- # For mcrypt and PHP 7.1
- sed -e '/error_reporting/s/. E_STRICT/- E_DEPRECATED/' -i test/bootstrap.php
- sed -e 's/colors=/convertErrorsToExceptions="false" colors=/' phpunit.xml.dist > phpunit.xml
- php71 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%if "%{php_version}" > "7.1"
- sed -e '/error_reporting/s/. E_STRICT/- E_DEPRECATED/' -i test/bootstrap.php
- sed -e 's/colors=/convertErrorsToExceptions="false" colors=/' phpunit.xml.dist > phpunit.xml
-%endif
-%{_bindir}/phpunit --verbose
-# remirepo:2
-fi
+for cmd in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" "php71 %{_bindir}/phpunit6" "php72 %{_bindir}/phpunit6"; do
+ if which $cmd; then
+ set $cmd
+ if [ $1 == php72 ]; then
+ sed -e '/error_reporting/s/. E_STRICT/- E_DEPRECATED/' -i test/bootstrap.php
+ sed -e 's/colors=/convertErrorsToExceptions="false" colors=/' phpunit.xml.dist > phpunit.xml
+ fi
+ $1 $2 || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
@@ -178,6 +169,10 @@ rm -rf %{buildroot}
%changelog
+* Mon May 22 2017 Remi Collet <remi@remirepo.net> - 2.7.2-1
+- Update to 2.7.2
+- use phpunit6 on F26+
+
* Wed Feb 22 2017 Remi Collet <remi@fedoraproject.org> - 2.7.1-3
- don't convertErrorsToExceptions, fix FTBFS #1424085