summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-feed.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-feed.spec')
-rw-r--r--php-zendframework-zend-feed.spec20
1 files changed, 6 insertions, 14 deletions
diff --git a/php-zendframework-zend-feed.spec b/php-zendframework-zend-feed.spec
index 83886ee..2058b55 100644
--- a/php-zendframework-zend-feed.spec
+++ b/php-zendframework-zend-feed.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit abe88686124d492e0a2a84656f15e5482bfbe030
+%global gh_commit 15a6ca78dd8f67b687e4f902657b4e420a8fd1e0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-feed
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.9.0
+Version: 2.9.1
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -60,11 +60,7 @@ BuildRequires: php-composer(%{gh_owner}/zend-db) >= 2.8.2
BuildRequires: php-composer(%{gh_owner}/zend-http) >= 2.7
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.8
BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.10.1
-%if 0%{?fedora} >= 26
-%global phpunit %{_bindir}/phpunit6
-%else
%global phpunit %{_bindir}/phpunit
-%endif
BuildRequires: %{phpunit}
# Because of boostraped Db
BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.5
@@ -91,13 +87,6 @@ Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
# "zendframework/zend-validator": "Zend\\Validator component, for validating feeds and Atom entries in the Writer subcomponent"
Requires: php-composer(psr/http-message) < 2
Requires: php-composer(psr/http-message) >= 1.0.1
-%if 0%{?fedora} >= 21
-Suggests: php-composer(%{gh_owner}/zend-cache)
-Suggests: php-composer(%{gh_owner}/zend-db)
-Suggests: php-composer(%{gh_owner}/zend-http)
-Suggests: php-composer(%{gh_owner}/zend-servicemanager)
-Suggests: php-composer(%{gh_owner}/zend-validator)
-%endif
%endif
# From phpcompatinfo report for version 2.6.0
Requires: php-ctype
@@ -165,7 +154,7 @@ require_once '%{php_home}/Zend/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" php70 php71 php72; do
if which $cmdarg; then
set $cmdarg
$1 -d memory_limit=1G ${2:-%{_bindir}/phpunit6} --verbose || ret=1
@@ -187,6 +176,9 @@ exit $ret
%changelog
+* Tue May 15 2018 Remi Collet <remi@remirepo.net> - 2.9.1-1
+- update to 2.9.1
+
* Tue Dec 5 2017 Remi Collet <remi@remirepo.net> - 2.9.0-1
- Update to 2.9.0
- raise dependency on zend-escaper 2.5.2