summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-15 07:19:38 +0200
committerRemi Collet <remi@remirepo.net>2018-05-15 07:19:38 +0200
commitc234d2303b3c9b36769326df3f76fd7fd6cdddfa (patch)
treed6077c8f9ec31a93c7a3a671265c620bd2a4c108
parentee9a8d416e45fbbdbb5aafdb5e6f48f69a87e376 (diff)
2.9.1
-rw-r--r--composer.json3
-rw-r--r--php-zendframework-zend-feed.spec20
2 files changed, 7 insertions, 16 deletions
diff --git a/composer.json b/composer.json
index b06ad84..73d7d84 100644
--- a/composer.json
+++ b/composer.json
@@ -65,7 +65,6 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
- "upload-coverage": "coveralls -v"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
}
diff --git a/php-zendframework-zend-feed.spec b/php-zendframework-zend-feed.spec
index 83886ee..2058b55 100644
--- a/php-zendframework-zend-feed.spec
+++ b/php-zendframework-zend-feed.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit abe88686124d492e0a2a84656f15e5482bfbe030
+%global gh_commit 15a6ca78dd8f67b687e4f902657b4e420a8fd1e0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-feed
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.9.0
+Version: 2.9.1
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -60,11 +60,7 @@ BuildRequires: php-composer(%{gh_owner}/zend-db) >= 2.8.2
BuildRequires: php-composer(%{gh_owner}/zend-http) >= 2.7
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.8
BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.10.1
-%if 0%{?fedora} >= 26
-%global phpunit %{_bindir}/phpunit6
-%else
%global phpunit %{_bindir}/phpunit
-%endif
BuildRequires: %{phpunit}
# Because of boostraped Db
BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.5
@@ -91,13 +87,6 @@ Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
# "zendframework/zend-validator": "Zend\\Validator component, for validating feeds and Atom entries in the Writer subcomponent"
Requires: php-composer(psr/http-message) < 2
Requires: php-composer(psr/http-message) >= 1.0.1
-%if 0%{?fedora} >= 21
-Suggests: php-composer(%{gh_owner}/zend-cache)
-Suggests: php-composer(%{gh_owner}/zend-db)
-Suggests: php-composer(%{gh_owner}/zend-http)
-Suggests: php-composer(%{gh_owner}/zend-servicemanager)
-Suggests: php-composer(%{gh_owner}/zend-validator)
-%endif
%endif
# From phpcompatinfo report for version 2.6.0
Requires: php-ctype
@@ -165,7 +154,7 @@ require_once '%{php_home}/Zend/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" php70 php71 php72; do
if which $cmdarg; then
set $cmdarg
$1 -d memory_limit=1G ${2:-%{_bindir}/phpunit6} --verbose || ret=1
@@ -187,6 +176,9 @@ exit $ret
%changelog
+* Tue May 15 2018 Remi Collet <remi@remirepo.net> - 2.9.1-1
+- update to 2.9.1
+
* Tue Dec 5 2017 Remi Collet <remi@remirepo.net> - 2.9.0-1
- Update to 2.9.0
- raise dependency on zend-escaper 2.5.2