summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-expressive-template.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-expressive-template.spec')
-rw-r--r--php-zendframework-zend-expressive-template.spec27
1 files changed, 5 insertions, 22 deletions
diff --git a/php-zendframework-zend-expressive-template.spec b/php-zendframework-zend-expressive-template.spec
index 146abd9..b9d02f4 100644
--- a/php-zendframework-zend-expressive-template.spec
+++ b/php-zendframework-zend-expressive-template.spec
@@ -31,7 +31,6 @@ URL: https://zendframework.github.io/zend-expressive/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -97,8 +96,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/%{library}
cp -pr src %{buildroot}%{php_home}/Zend/%{library}/%{sublib}
@@ -120,33 +117,19 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if which php71; then
- php70 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md