summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-diactoros.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-diactoros.spec')
-rw-r--r--php-zendframework-zend-diactoros.spec19
1 files changed, 15 insertions, 4 deletions
diff --git a/php-zendframework-zend-diactoros.spec b/php-zendframework-zend-diactoros.spec
index 5ddfef3..53001ac 100644
--- a/php-zendframework-zend-diactoros.spec
+++ b/php-zendframework-zend-diactoros.spec
@@ -12,15 +12,15 @@
%global github_owner zendframework
%global github_name zend-diactoros
-%global github_version 1.7.2
-%global github_commit 741e7a571836f038de731105f4742ca8a164e43a
+%global github_version 1.8.4
+%global github_commit 736ffa7c2bfa4a60e8a10acb316fa2ac456c5fba
%global composer_vendor zendframework
%global composer_project zend-diactoros
# "php": "^5.6 || ^7.0"
%global php_min_ver 5.6
-# "psr/http-message": "~1.0"
+# "psr/http-message": "^1.0"
%global psr_http_message_min_ver 1.0
%global psr_http_message_max_ver 2.0
@@ -122,6 +122,14 @@ phpab --template fedora --output src/autoload.php src
cat <<'AUTOLOAD' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required(array(
'%{phpdir}/Psr/Http/Message/autoload.php',
+ __DIR__.'/functions/create_uploaded_file.php',
+ __DIR__.'/functions/marshal_headers_from_sapi.php',
+ __DIR__.'/functions/marshal_method_from_sapi.php',
+ __DIR__.'/functions/marshal_protocol_version_from_sapi.php',
+ __DIR__.'/functions/marshal_uri_from_sapi.php',
+ __DIR__.'/functions/normalize_server.php',
+ __DIR__.'/functions/normalize_uploaded_files.php',
+ __DIR__.'/functions/parse_cookie_header.php',
));
AUTOLOAD
@@ -152,7 +160,7 @@ sed 's/function testReasonPhraseDefaultsAgainstIana/function SKIP_testReasonPhra
: Upstream tests
RETURN_CODE=0
-for CMDARG in "php %{phpunit}" php70 php71 php72; do
+for CMDARG in "php %{phpunit}" php70 php71 php72 php73; do
if which $CMDARG; then
set $CMDARG
$1 ${2:-%{_bindir}/phpunit6} --bootstrap bootstrap.php --verbose \
@@ -175,6 +183,9 @@ exit $RETURN_CODE
%changelog
+* Thu Aug 02 2018 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.8.4-1
+- Update to 1.8.4 (RHBZ #1504401 / ZF2018-01 / CVE-2018-14773 / CVE-2018-14774)
+
* Wed May 30 2018 Remi Collet <remi@remirepo.net> - 1.7.2-1
- update to 1.7.2