summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-08-11 13:32:48 +0200
committerRemi Collet <fedora@famillecollet.com>2015-08-11 13:32:48 +0200
commit76f642441f458d5feafd50a6b03e769e99821ca1 (patch)
treeecc56e27da11f6987ffc10289f7a0aafa6fef664
move php-zendframework-zend-diactoros
-rw-r--r--Makefile4
-rwxr-xr-xphp-zendframework-zend-diactoros-get-source.sh69
-rw-r--r--php-zendframework-zend-diactoros.spec176
3 files changed, 249 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/php-zendframework-zend-diactoros-get-source.sh b/php-zendframework-zend-diactoros-get-source.sh
new file mode 100755
index 0000000..ba71f5d
--- /dev/null
+++ b/php-zendframework-zend-diactoros-get-source.sh
@@ -0,0 +1,69 @@
+#/bin/sh
+
+GIT=`which git`
+RPM=`which rpm`
+
+if [ -z "$GIT" ]
+then
+ echo "ERROR: 'git' command not found" 1>&2
+ exit 1
+elif [ -z "$RPM" ]
+then
+ echo "ERROR: 'rpm' command not found" 1>&2
+ exit 1
+fi
+
+function print {
+ echo -e "\e[0;33m>>>>> ${1}\e[0m"
+}
+
+if [ -x "$1" ]
+then
+ SPEC=$1
+else
+ SPEC=`ls *.spec | head -1`
+fi
+
+NAME=`echo $SPEC | sed 's#\.spec##'`
+VERSION=`egrep '%global\s*github_version' $SPEC | awk '{print $3}'`
+
+print "SPEC = $SPEC"
+print "NAME = $NAME"
+
+GIT_OWNER=`egrep '%global\s*github_owner' $SPEC | awk '{print $3}'`
+GIT_NAME=`egrep '%global\s*github_name' $SPEC | awk '{print $3}'`
+GIT_COMMIT=`egrep '%global\s*github_commit' $SPEC | awk '{print $3}'`
+GIT_REPO=https://github.com/${GIT_OWNER}/${GIT_NAME}
+GIT_DIR=`echo $GIT_REPO | sed 's#.*/##'`
+
+print "GIT_OWNER = $GIT_OWNER"
+print "GIT_NAME = $GIT_NAME"
+print "GIT_COMMIT = $GIT_COMMIT"
+print "GIT_REPO = $GIT_REPO"
+print "GIT_DIR = $GIT_DIR"
+
+TEMP_DIR=$(mktemp --dir)
+
+pushd $TEMP_DIR
+ print "Cloning git repo..."
+ $GIT clone $GIT_REPO
+
+ pushd $GIT_DIR
+ print "Checking out commit..."
+ $GIT checkout $GIT_COMMIT
+ popd
+
+ TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
+ print "TAR_DIR = $TAR_DIR"
+
+ mv $GIT_DIR $TAR_DIR
+
+ TAR_FILE=`$RPM --eval='%{_sourcedir}'`/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
+ print "TAR_FILE = $TAR_FILE"
+
+ [ -e $TAR_FILE ] && rm -f $TAR_FILE
+ tar --exclude-vcs -czf $TAR_FILE $TAR_DIR
+ chmod 0644 $TAR_FILE
+popd
+
+rm -rf $TEMP_DIR
diff --git a/php-zendframework-zend-diactoros.spec b/php-zendframework-zend-diactoros.spec
new file mode 100644
index 0000000..4a90a70
--- /dev/null
+++ b/php-zendframework-zend-diactoros.spec
@@ -0,0 +1,176 @@
+# remirepo spec file for php-zendframework-zend-diactoros, from
+#
+# Fedora spec file for php-zendframework-zend-diactoros
+#
+# Copyright (c) 2015 Shawn Iwinski <shawn.iwinski@gmail.com>
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
+
+%global github_owner zendframework
+%global github_name zend-diactoros
+%global github_version 1.1.2
+%global github_commit eeedadd333b80bb5d93559e2285047463fe4fe33
+
+%global composer_vendor zendframework
+%global composer_project zend-diactoros
+
+# "php": ">=5.4"
+%global php_min_ver 5.4
+# "psr/http-message": "~1.0"
+%global psr_http_message_min_ver 1.0
+%global psr_http_message_max_ver 2.0
+
+# Build using "--without tests" to disable tests
+%global with_tests 0%{!?_without_tests:1}
+
+%{!?phpdir: %global phpdir %{_datadir}/php}
+
+Name: php-%{composer_vendor}-%{composer_project}
+Version: %{github_version}
+Release: 1%{?github_release}%{?dist}
+Summary: PSR HTTP Message implementations
+
+Group: Development/Libraries
+License: BSD
+URL: https://github.com/%{github_owner}/%{github_name}
+
+# GitHub export does not include tests.
+# Run php-zendframework-zend-diactoros-get-source.sh to create full source.
+Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
+Source1: %{name}-get-source.sh
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+## composer.json
+BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: php-composer(phpunit/phpunit)
+BuildRequires: php-composer(psr/http-message) >= %{psr_http_message_min_ver}
+## phpcompatinfo (computed from version 1.1.2)
+BuildRequires: php-json
+BuildRequires: php-pcre
+BuildRequires: php-spl
+## Autoloader
+BuildRequires: php-composer(symfony/class-loader)
+%endif
+
+# composer.json
+Requires: php(language) >= %{php_min_ver}
+Requires: php-composer(psr/http-message) >= %{psr_http_message_min_ver}
+Requires: php-composer(psr/http-message) < %{psr_http_message_max_ver}
+# phpcompatinfo (computed from version 1.1.2)
+Requires: php-json
+Requires: php-pcre
+Requires: php-spl
+# Autoloader
+Requires: php-composer(symfony/class-loader)
+
+# Composer
+Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
+Provides: php-composer(psr/http-message-implementation) = 1.0.0
+
+%description
+A PHP package containing implementations of the accepted PSR-7 HTTP message
+interfaces [1], as well as a "server" implementation similar to node's
+http.Server [2].
+
+[1] http://www.php-fig.org/psr/psr-7/
+[2] http://nodejs.org/api/http.html
+
+
+%prep
+%setup -qn %{github_name}-%{github_commit}
+
+: Create autoloader
+cat <<'AUTOLOAD' | tee src/autoload.php
+<?php
+/**
+ * Autoloader for %{name} and its' dependencies
+ *
+ * Created by %{name}-%{version}-%{release}
+ *
+ * @return \Symfony\Component\ClassLoader\ClassLoader
+ */
+
+require_once '%{phpdir}/Psr/Http/Message/autoload.php';
+
+if (!isset($fedoraClassLoader) || !($fedoraClassLoader instanceof \Symfony\Component\ClassLoader\ClassLoader)) {
+ if (!class_exists('Symfony\\Component\\ClassLoader\\ClassLoader', false)) {
+ require_once '%{phpdir}/Symfony/Component/ClassLoader/ClassLoader.php';
+ }
+
+ $fedoraClassLoader = new \Symfony\Component\ClassLoader\ClassLoader();
+ $fedoraClassLoader->register();
+}
+
+$fedoraClassLoader->addPrefix('Zend\\Diactoros\\', dirname(dirname(__DIR__)));
+
+return $fedoraClassLoader;
+AUTOLOAD
+
+
+%build
+# Empty build section, nothing required
+
+
+%install
+rm -rf %{buildroot}
+
+mkdir -p %{buildroot}%{phpdir}/Zend/Diactoros
+cp -rp src/* %{buildroot}%{phpdir}/Zend/Diactoros/
+
+
+%check
+%if %{with_tests}
+: Create tests bootstrap
+cat <<'BOOTSTRAP' | tee bootstrap.php
+<?php
+
+$fedoraClassLoader =
+ require_once '%{buildroot}%{phpdir}/Zend/Diactoros/autoload.php';
+
+$fedoraClassLoader->addPrefix('ZendTest\\Diactoros\\', __DIR__ . '/test');
+
+require_once __DIR__ . '/test/TestAsset/Functions.php';
+require_once __DIR__ . '/test/TestAsset/SapiResponse.php';
+BOOTSTRAP
+
+%{_bindir}/phpunit --verbose --bootstrap ./bootstrap.php
+%else
+: Tests skipped
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE.md
+%doc CHANGELOG.md
+%doc CONTRIBUTING.md
+%doc README.md
+%doc composer.json
+%dir %{phpdir}/Zend
+ %{phpdir}/Zend/Diactoros
+
+
+%changelog
+* Mon Jul 20 2015 Remi Collet <remi@remirepo.net> - 1.1.2-1
+- add EL-5 stuff, backport for #remirepo
+
+* Wed Jul 15 2015 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.1.2-1
+- Update to 1.1.2
+- Fix license
+- Update description
+- Use full path in autoloader
+
+* Wed Jul 08 2015 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.1.1-1
+- Initial package