summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-debug.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-debug.spec')
-rw-r--r--php-zendframework-zend-debug.spec34
1 files changed, 16 insertions, 18 deletions
diff --git a/php-zendframework-zend-debug.spec b/php-zendframework-zend-debug.spec
index cd03e0c..bd45b76 100644
--- a/php-zendframework-zend-debug.spec
+++ b/php-zendframework-zend-debug.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit b6f9df59155391ca683c479a0d758f66ef73b3b3
+%global gh_commit cb423facd6f2e875a3cb44cf992b6bd1f5fd1a96
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-debug
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.1
+Version: 2.6.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -34,29 +34,26 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.3.23
+BuildRequires: php(language) >= 5.6
BuildRequires: php-pcre
-# From composer, "require-dev": {
-# "zendframework/zend-escaper": "2.*",
-# "fabpot/php-cs-fixer": "1.7.*",
-# "phpunit/PHPUnit": "~4.0"
BuildRequires: php-composer(%{gh_owner}/zend-escaper) >= 2.5
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+# From composer, "require-dev": {
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.5",
+# "zendframework/zend-coding-standard": "~1.0.0"
+BuildRequires: php-composer(phpunit/phpunit) >= 5.7.27
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": ">=5.3.23"
-Requires: php(language) >= 5.3.23
+# "php": "^5.6 || ^7.0",
+# "zendframework/zend-escaper": "^2.0"
+Requires: php(language) >= 5.6
%if ! %{bootstrap}
+Requires: php-composer(%{gh_owner}/zend-escaper)
# From composer, "suggest": {
# "ext/xdebug": "XDebug, for better backtrace output",
# "zendframework/zend-escaper": "To support escaped output"
-%if 0%{?fedora} >= 21
-Suggests: php-pecl(xdebug)
-Suggests: php-composer(%{gh_owner}/zend-escaper)
-%endif
# Autoloader
Requires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
@@ -111,10 +108,6 @@ require_once '%{php_home}/Zend/autoload.php';
EOF
%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-
-if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-fi
%else
: Test suite disabled
%endif
@@ -134,5 +127,10 @@ rm -rf %{buildroot}
%changelog
+* Wed May 2 2018 Remi Collet <remi@remirepo.net> - 2.6.0-1
+- update to 2.6.0
+- raise dependency on PHP 5.6
+- add dependency on zend-escaper
+
* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
- initial package