summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-04-11 13:09:01 +0200
committerRemi Collet <remi@remirepo.net>2018-04-11 13:09:01 +0200
commit08fff2499d0543253229a7d41b63c1e8afe372d6 (patch)
tree696b40b6a06ce9938367f33d557761b0dec669a0
parent134eb252212fcd1e89f91921750d8457254b3d58 (diff)
v2.9.3
-rw-r--r--composer.json6
-rw-r--r--php-zendframework-zend-db.spec14
2 files changed, 13 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index b4cc8c7..f9f96e4 100644
--- a/composer.json
+++ b/composer.json
@@ -41,7 +41,8 @@
"test/autoload.php"
],
"psr-4": {
- "ZendTest\\Db\\": "test/"
+ "ZendTest\\Db\\": "test/unit",
+ "ZendIntegrationTest\\Db\\": "test/integration"
}
},
"config": {
@@ -64,8 +65,9 @@
],
"cs-check": "phpcs",
"cs-fix": "phpcbf",
- "test": "phpunit --colors=always",
+ "test": "phpunit --colors=always --testsuite \"unit test\"",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
+ "test-integration" : "phpunit --colors=always --testsuite \"integration test\"",
"upload-coverage": "coveralls -v"
}
}
diff --git a/php-zendframework-zend-db.spec b/php-zendframework-zend-db.spec
index d063e0c..4ff289e 100644
--- a/php-zendframework-zend-db.spec
+++ b/php-zendframework-zend-db.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-db
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 1651abb1b33fc8fbd2d78ff9e2abb526cc2cf666
+%global gh_commit 5b4f2c42f94c9f7f4b2f456a0ebe459fab12b3d9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-db
@@ -24,7 +24,7 @@
# must be compatible with PHPUnit\Framework\TestListener::addError(PHPUnit\Framework\Test $test, Exception $e, $time) ...
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.9.2
+Version: 2.9.3
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -125,14 +125,15 @@ require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
Zend\Loader\AutoloaderFactory::factory(array(
'Zend\Loader\StandardAutoloader' => array(
'namespaces' => array(
- 'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
+ 'ZendTest\\%{library}' => dirname(__DIR__).'/test/unit/',
+ 'ZendIntegrationTest\\%{library}' => dirname(__DIR__).'/test/integration/',
'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" php70 php71 php72; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
@@ -153,6 +154,9 @@ exit $ret
%changelog
+* Wed Apr 11 2018 Remi Collet <remi@remirepo.net> - 2.9.3-1
+- update to 2.9.3
+
* Tue Dec 12 2017 Remi Collet <remi@remirepo.net> - 2.9.2-1
- Update to 2.9.2