summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-code.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-code.spec')
-rw-r--r--php-zendframework-zend-code.spec26
1 files changed, 14 insertions, 12 deletions
diff --git a/php-zendframework-zend-code.spec b/php-zendframework-zend-code.spec
index 63eb84a..beadc65 100644
--- a/php-zendframework-zend-code.spec
+++ b/php-zendframework-zend-code.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 936fa7ad4d53897ea3e3eb41b5b760828246a20b
+%global gh_commit 46feaeecea14161734b56c1ace74f28cb329f194
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-code
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 3.3.2
-Release: 2%{?dist}
+Version: 3.4.0
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
License: BSD
@@ -29,12 +29,10 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: https://patch-diff.githubusercontent.com/raw/zendframework/zend-code/pull/172.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.1
+BuildRequires: php(language) >= 7.2
BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
@@ -45,12 +43,12 @@ BuildRequires: (php-autoloader(%{gh_owner}/zend-eventmanager) >= 2.6 with p
# From composer, "require-dev": {
# "ext-phar": "*",
# "doctrine/annotations": "^1.0",
-# "phpunit/phpunit": "^7.5.15",
+# "phpunit/phpunit": "^7.5.16 || ^8.4,"
# "zendframework/zend-coding-standard": "^1.0",
# "zendframework/zend-stdlib": "^2.7 || ^3.0"
BuildRequires: (php-composer(doctrine/annotations) >= 1.0 with php-composer(doctrine/annotations) < 2)
BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-# remirepo:4
+# remirepo:8
%else
BuildRequires: php-autoloader(%{gh_owner}/zend-eventmanager) < 4
BuildRequires: php-autoloader(%{gh_owner}/zend-eventmanager) >= 2.6
@@ -59,7 +57,7 @@ BuildRequires: php-composer(doctrine/annotations) >= 1.0
BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
%endif
-BuildRequires: phpunit7 >= 7.5
+BuildRequires: phpunit8 >= 8.4
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -110,7 +108,6 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
mv LICENSE.md LICENSE
@@ -144,9 +141,9 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
EOF
ret=0
-for cmd in php php71 php72 php73 php74; do
+for cmd in php php72 php73 php74; do
if which $cmd; then
- $cmd %{_bindir}/phpunit7 --verbose || ret=1
+ $cmd %{_bindir}/phpunit8 --verbose || ret=1
fi
done
exit $ret
@@ -164,6 +161,11 @@ exit $ret
%changelog
+* Mon Oct 7 2019 Remi Collet <remi@remirepo.net> - 3.4.0-1
+- update to 3.4.0
+- drop patch merged upstream
+- use phpunit8
+
* Mon Sep 2 2019 Remi Collet <remi@remirepo.net> - 3.3.2-2
- update to 3.3.2
- use phpunit7