summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-04-26 08:12:17 +0200
committerRemi Collet <remi@remirepo.net>2018-04-26 08:12:17 +0200
commit0a438ea6cfb449635ada2f91153f19f06a84027b (patch)
tree771a3e0ce67462100ba905d2aca3969d1b8edc61
parent280a90c3235bc1770a48c88166a872ee88a7b162 (diff)
update to 2.8.0
raise dependency on PHP 5.6 add dependency on psr/cache add dependency on psr/simple-cache
-rw-r--r--composer.json82
-rw-r--r--php-zendframework-zend-cache.spec79
2 files changed, 103 insertions, 58 deletions
diff --git a/composer.json b/composer.json
index 77a87b4..7d8f29f 100644
--- a/composer.json
+++ b/composer.json
@@ -1,29 +1,37 @@
{
"name": "zendframework/zend-cache",
- "description": "provides a generic way to cache any data",
+ "description": "Caching implementation with a variety of storage options, as well as codified caching strategies for callbacks, classes, and output",
"license": "BSD-3-Clause",
"keywords": [
- "zf2",
- "cache"
+ "zendframework",
+ "zf",
+ "cache",
+ "psr-6",
+ "psr-16"
],
- "homepage": "https://github.com/zendframework/zend-cache",
- "autoload": {
- "psr-4": {
- "Zend\\Cache\\": "src/"
- }
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-cache/",
+ "issues": "https://github.com/zendframework/zend-cache/issues",
+ "source": "https://github.com/zendframework/zend-cache",
+ "rss": "https://github.com/zendframework/zend-cache/releases.atom",
+ "chat": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
},
"require": {
- "php": "^5.5 || ^7.0",
- "zendframework/zend-stdlib": "^2.7 || ^3.0",
- "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
- "zendframework/zend-eventmanager": "^2.6.2 || ^3.0"
+ "php": "^5.6 || ^7.0",
+ "psr/cache": "^1.0",
+ "psr/simple-cache": "^1.0",
+ "zendframework/zend-eventmanager": "^2.6.3 || ^3.2",
+ "zendframework/zend-servicemanager": "^2.7.8 || ^3.3",
+ "zendframework/zend-stdlib": "^2.7.7 || ^3.1"
},
"require-dev": {
+ "cache/integration-tests": "^0.16",
+ "phpbench/phpbench": "^0.13",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
+ "zendframework/zend-coding-standard": "~1.0.0",
"zendframework/zend-serializer": "^2.6",
- "zendframework/zend-session": "^2.6.2",
- "phpunit/phpunit": "^4.8",
- "phpbench/phpbench": "^0.10.0",
- "zendframework/zend-coding-standard": "~1.0.0"
+ "zendframework/zend-session": "^2.7.4"
},
"suggest": {
"zendframework/zend-serializer": "Zend\\Serializer component",
@@ -34,27 +42,46 @@
"ext-memcache": "Memcache >= 2.0.0 to use the Memcache storage adapter",
"ext-memcached": "Memcached >= 1.0.0 to use the Memcached storage adapter",
"ext-mongo": "Mongo, to use MongoDb storage adapter",
+ "ext-mongodb": "MongoDB, to use the ExtMongoDb storage adapter",
"ext-redis": "Redis, to use Redis storage adapter",
"ext-wincache": "WinCache, to use the WinCache storage adapter",
"ext-xcache": "XCache, to use the XCache storage adapter",
+ "mongodb/mongodb": "Required for use with the ext-mongodb adapter",
"mongofill/mongofill": "Alternative to ext-mongo - a pure PHP implementation designed as a drop in replacement"
},
- "minimum-stability": "dev",
- "prefer-stable": true,
- "extra": {
- "branch-alias": {
- "dev-master": "2.7-dev",
- "dev-develop": "2.8-dev"
- },
- "zf": {
- "component": "Zend\\Cache",
- "config-provider": "Zend\\Cache\\ConfigProvider"
+ "autoload": {
+ "files": [
+ "autoload/patternPluginManagerPolyfill.php"
+ ],
+ "psr-4": {
+ "Zend\\Cache\\": "src/"
}
},
"autoload-dev": {
"psr-4": {
"ZendTest\\Cache\\": "test/",
"ZendBench\\Cache\\": "benchmark/"
+ },
+ "files": [
+ "test/autoload.php"
+ ]
+ },
+ "config": {
+ "process-timeout": 600,
+ "sort-packages": true
+ },
+ "provide": {
+ "psr/cache-implementation": "1.0",
+ "psr/simple-cache-implementation": "1.0"
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.8.x-dev",
+ "dev-develop": "2.9.x-dev"
+ },
+ "zf": {
+ "component": "Zend\\Cache",
+ "config-provider": "Zend\\Cache\\ConfigProvider"
}
},
"scripts": {
@@ -65,7 +92,6 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
- "upload-coverage": "coveralls -v"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
}
diff --git a/php-zendframework-zend-cache.spec b/php-zendframework-zend-cache.spec
index ae2dfcc..281fd2c 100644
--- a/php-zendframework-zend-cache.spec
+++ b/php-zendframework-zend-cache.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit c98331b96d3b9d9b24cf32d02660602edb34d039
+%global gh_commit e57717839e040227133f1df8d158a05f85a7be6c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-cache
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.2
-Release: 5%{?dist}
+Version: 2.8.0
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -30,45 +30,58 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: https://github.com/zendframework/zend-cache/commit/d967c0d39c48a79c3c37ff84d8658240038f4d78.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
BuildRequires: php-reflection
BuildRequires: php-date
BuildRequires: php-pcre
BuildRequires: php-spl
-BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
-BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
-BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6.2
+BuildRequires: php-composer(psr/cache) < 2
+BuildRequires: php-composer(psr/cache) >= 1.0
+BuildRequires: php-composer(psr/simple-cache) < 2
+BuildRequires: php-composer(psr/simple-cache) >= 1.0
+BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) < 4
+BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6.3
+BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) < 4
+BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.8
+BuildRequires: php-composer(%{gh_owner}/zend-stdlib) < 4
+BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7.7
# From composer, "require-dev": {
+# "cache/integration-tests": "^0.16",
+# "phpbench/phpbench": "^0.13",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
+# "zendframework/zend-coding-standard": "~1.0.0",
# "zendframework/zend-serializer": "^2.6",
-# "zendframework/zend-session": "^2.6.2",
-# "phpunit/phpunit": "^4.8",
-# "phpbench/phpbench": "^0.10.0",
-# "zendframework/zend-coding-standard": "~1.0.0"
+# "zendframework/zend-session": "^2.7.4"
+BuildRequires: php-composer(cache/integration-tests) >= 0.16
+BuildRequires: php-composer(phpunit/phpunit) >= 5.7
BuildRequires: php-composer(%{gh_owner}/zend-serializer) >= 2.6
-BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.6.2
-BuildRequires: php-composer(phpunit/phpunit) >= 4.8
+BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.7.4
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": "^5.5 || ^7.0",
-# "zendframework/zend-stdlib": "^2.7 || ^3.0",
-# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
-# "zendframework/zend-eventmanager": "^2.6.2 || ^3.0"
-Requires: php(language) >= 5.5
+# "php": "^5.6 || ^7.0",
+# "psr/cache": "^1.0",
+# "psr/simple-cache": "^1.0",
+# "zendframework/zend-eventmanager": "^2.6.3 || ^3.2",
+# "zendframework/zend-servicemanager": "^2.7.8 || ^3.3",
+# "zendframework/zend-stdlib": "^2.7.7 || ^3.1"
+Requires: php(language) >= 5.6
%if ! %{bootstrap}
-Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
-Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
-Requires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
-Requires: php-composer(%{gh_owner}/zend-servicemanager) < 4
-Requires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6.2
+Requires: php-composer(psr/cache) < 2
+Requires: php-composer(psr/cache) >= 1.0
+Requires: php-composer(psr/simple-cache) < 2
+Requires: php-composer(psr/simple-cache) >= 1.0
Requires: php-composer(%{gh_owner}/zend-eventmanager) < 4
+Requires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6.3
+Requires: php-composer(%{gh_owner}/zend-servicemanager) < 4
+Requires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.8
+Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
+Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7.7
# From composer, "suggest": {
# "zendframework/zend-serializer": "Zend\\Serializer component",
# "zendframework/zend-session": "Zend\\Session component",
@@ -109,6 +122,8 @@ Provides: php-ZendFramework2-%{library} = %{version}
Provides: php-ZendFramework2-%{library}-apc = %{version}
Provides: php-ZendFramework2-%{library}-memcached = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(psr/cache-implementation) = 1.0
+Provides: php-composer(psr/simple-cache-implementation) = 1.0
%description
@@ -122,10 +137,6 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-# EL-6 patch don't allow rename
-mkdir src/PatternPluginManager
-mv src/PatternPluginManager.php src/PatternPluginManager/PatternPluginManagerV2Polyfill.php
-%patch0 -p1
mv LICENSE.md LICENSE
@@ -135,6 +146,8 @@ mv autoload/*.php src
cat << 'EOF' | tee autoload.php
<?php
require_once __DIR__ . '/%{library}/patternPluginManagerPolyfill.php';
+require_once '%{php_home}/Psr/Cache/autoload.php';
+require_once '%{php_home}/Psr/SimpleCache/autoload.php';
EOF
@@ -174,7 +187,7 @@ sed -e '/unlinkDelay/s/5000/50000/' \
ret=0
for cmd in php php56 php70 php71 php72; do
if which $cmd; then
- $cmd %{_bindir}/phpunit || ret=1
+ $cmd -d memory_limit=1G %{_bindir}/phpunit || ret=1
fi
done
exit $ret
@@ -193,6 +206,12 @@ exit $ret
%changelog
+* Thu Apr 26 2018 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- update to 2.8.0
+- raise dependency on PHP 5.6
+- add dependency on psr/cache
+- add dependency on psr/simple-cache
+
* Tue Nov 14 2017 Remi Collet <remi@fedoraproject.org> - 2.7.2-5
- try to slowdown tests with erratic result (FTBFS)