summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-barcode.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-barcode.spec')
-rw-r--r--php-zendframework-zend-barcode.spec29
1 files changed, 15 insertions, 14 deletions
diff --git a/php-zendframework-zend-barcode.spec b/php-zendframework-zend-barcode.spec
index 39d68db..e8fbe76 100644
--- a/php-zendframework-zend-barcode.spec
+++ b/php-zendframework-zend-barcode.spec
@@ -21,7 +21,7 @@
Name: php-%{gh_owner}-%{gh_project}
Version: 2.6.0
-Release: 1%{?dist}
+Release: 4%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -30,7 +30,8 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+Patch0: https://github.com/zendframework/zend-barcode/pull/36.patch
+
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -97,6 +98,7 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
mv LICENSE.md LICENSE
@@ -106,8 +108,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -127,22 +127,19 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-
-if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-fi
+ret=0
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit || ret=1
+ fi
+done
+exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -151,6 +148,10 @@ rm -rf %{buildroot}
%changelog
+* Fri Oct 20 2017 Remi Collet <remi@fedoraproject.org> - 2.6.0-4
+- fix FTBFS from Koschei, add patch for PHP 7.2 from
+ https://github.com/zendframework/zend-barcode/pull/36
+
* Thu Feb 18 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
- update to 2.6.0
- raise dependency on zend-stdlib ^2.7