summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-authentication.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-authentication.spec')
-rw-r--r--php-zendframework-zend-authentication.spec54
1 files changed, 29 insertions, 25 deletions
diff --git a/php-zendframework-zend-authentication.spec b/php-zendframework-zend-authentication.spec
index 08a5c01..a3723f8 100644
--- a/php-zendframework-zend-authentication.spec
+++ b/php-zendframework-zend-authentication.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 1002b40baa9acb3f875cc77f4a2b4fc238b62170
+%global gh_commit 1422dec160eb769c719cad2229847fcbf20a1405
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-authentication
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.2
+Version: 2.5.3
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -42,21 +42,21 @@ BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
# From composer, "require-dev": {
-# "zendframework/zend-db": "~2.5",
-# "zendframework/zend-crypt": "~2.5",
-# "zendframework/zend-http": "~2.5",
-# "zendframework/zend-ldap": "~2.5",
-# "zendframework/zend-session": "~2.5",
-# "zendframework/zend-validator": "~2.5",
-# "zendframework/zend-uri": "~2.5",
+# "zendframework/zend-db": "^2.7",
+# "zendframework/zend-crypt": "^2.6",
+# "zendframework/zend-http": "^2.5.4",
+# "zendframework/zend-ldap": "^2.6",
+# "zendframework/zend-session": "^2.6.2",
+# "zendframework/zend-validator": "^2.6",
+# "zendframework/zend-uri": "^2.5",
# "fabpot/php-cs-fixer": "1.7.*",
# "phpunit/PHPUnit": "~4.0"
-BuildRequires: php-composer(%{gh_owner}/zend-db) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-crypt) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-http) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-ldap) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-db) >= 2.7
+BuildRequires: php-composer(%{gh_owner}/zend-crypt) >= 2.6
+BuildRequires: php-composer(%{gh_owner}/zend-http) >= 2.5.4
+BuildRequires: php-composer(%{gh_owner}/zend-ldap) >= 2.6
+BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.6.2
+BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-uri) >= 2.5
BuildRequires: php-composer(phpunit/phpunit) >= 4.0
# Autoloader
@@ -64,12 +64,12 @@ BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": ">=5.5",
-# "zendframework/zend-stdlib": "~2.5"
+# "php": "^5.5 || ^7.0",
+# "zendframework/zend-stdlib": "^2.7 || ^3.0"
Requires: php(language) >= 5.5
%if ! %{bootstrap}
-Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
-Requires: php-composer(%{gh_owner}/zend-stdlib) < 3
+Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
+Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
# From composer, "suggest": {
# "zendframework/zend-db": "Zend\\Db component",
# "zendframework/zend-crypt": "Zend\\Crypt component",
@@ -123,14 +123,14 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
%check
%if %{with_tests}
mkdir vendor
-cat << EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
-Zend\\Loader\\AutoloaderFactory::factory(array(
- 'Zend\\Loader\\StandardAutoloader' => array(
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
'namespaces' => array(
- 'ZendTest\\\\%{library}' => dirname(__DIR__).'/test/',
- 'Zend\\\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
+ 'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
+ 'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
@@ -159,5 +159,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Feb 28 2016 Remi Collet <remi@fedoraproject.org> - 2.5.3-1
+- update to 2.5.3
+- raise dependency on zend-stdlib ~2.7
+
* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.2-1
-- initial package \ No newline at end of file
+- initial package