summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-11 09:41:11 +0100
committerRemi Collet <remi@remirepo.net>2017-12-11 09:41:11 +0100
commit645f725d8d26c7565f4906803680888613a6c422 (patch)
tree82ee4910fb56f4431d41f04bf373eebf4e343236
parent0ff0b17a4d602f4942b247a2636a0bf274250960 (diff)
clean
-rw-r--r--php-zendframework-zend-authentication.spec20
1 files changed, 7 insertions, 13 deletions
diff --git a/php-zendframework-zend-authentication.spec b/php-zendframework-zend-authentication.spec
index f339305..056539d 100644
--- a/php-zendframework-zend-authentication.spec
+++ b/php-zendframework-zend-authentication.spec
@@ -30,7 +30,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -118,8 +117,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -139,22 +136,19 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-
-if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-fi
+ret=0
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit || ret=1
+ fi
+done
+exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md