summaryrefslogtreecommitdiffstats
path: root/php-twig3.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-twig3.spec')
-rw-r--r--php-twig3.spec19
1 files changed, 13 insertions, 6 deletions
diff --git a/php-twig3.spec b/php-twig3.spec
index 0267612..8e8af52 100644
--- a/php-twig3.spec
+++ b/php-twig3.spec
@@ -13,7 +13,7 @@
%global with_tests 0%{!?_without_tests:1}
%global github_owner twigphp
%global github_name Twig
-%global github_commit 582bdbdc173027ebfba3c93dc750a40b8f9ebc02
+%global github_commit 9b76b1535483cdf4edf01bb787b0217b62bd68a5
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global composer_vendor twig
@@ -26,7 +26,7 @@
%global phpdir %{_datadir}/php
Name: php-%{composer_project}%{major}
-Version: 3.0.4
+Version: 3.0.5
Release: 1%{?dist}
Summary: The flexible, fast, and secure template engine for PHP
@@ -41,14 +41,15 @@ BuildRequires: php-fedora-autoloader-devel
%if %{with_tests}
# For tests
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: phpunit8
# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8
BuildRequires: (php-composer(psr/container) >= 1.0 with php-composer(psr/container) < 2)
# remirepo:3
%else
BuildRequires: php-psr-container >= 1.0
%endif
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: %{phpunit}
# Workaround
BuildRequires: php-symfony-common
## phpcompatinfo (computed from version 3.0.0)
@@ -140,9 +141,11 @@ sed -e '/listener/d' phpunit.xml.dist > phpunit.xml
RETURN_CODE=0
: Upstream tests with SCLs if available
-for SCL in php php72 php73 php74 php80; do
+for SCL in "php %{phpunit}" php73 php74 php80; do
if which $SCL; then
- $SCL %{_bindir}/phpunit8 --verbose || RETURN_CODE=1
+ set $SCL
+ $1 ${2:-%{_bindir}/phpunit9} \
+ --verbose || RETURN_CODE=1
fi
done
exit $RETURN_CODE
@@ -160,6 +163,10 @@ exit $RETURN_CODE
%changelog
+* Tue Aug 11 2020 Remi Collet <remi@remirepo.net> - 3.0.5-1
+- update to 3.0.5
+- switch to phpunit9
+
* Mon Jul 6 2020 Remi Collet <remi@remirepo.net> - 3.0.4-1
- update to 3.0.4