summaryrefslogtreecommitdiffstats
path: root/php-twig3.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-twig3.spec')
-rw-r--r--php-twig3.spec15
1 files changed, 9 insertions, 6 deletions
diff --git a/php-twig3.spec b/php-twig3.spec
index cd886d1..0267612 100644
--- a/php-twig3.spec
+++ b/php-twig3.spec
@@ -13,7 +13,7 @@
%global with_tests 0%{!?_without_tests:1}
%global github_owner twigphp
%global github_name Twig
-%global github_commit 3b88ccd180a6b61ebb517aea3b1a8906762a1dc2
+%global github_commit 582bdbdc173027ebfba3c93dc750a40b8f9ebc02
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global composer_vendor twig
@@ -21,12 +21,12 @@
%global major 3
-# "php": "^7.2.5"
+# "php": ">=7.2.5"
%global php_min_ver 7.2.5
%global phpdir %{_datadir}/php
Name: php-%{composer_project}%{major}
-Version: 3.0.3
+Version: 3.0.4
Release: 1%{?dist}
Summary: The flexible, fast, and secure template engine for PHP
@@ -41,7 +41,7 @@ BuildRequires: php-fedora-autoloader-devel
%if %{with_tests}
# For tests
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: phpunit7
+BuildRequires: phpunit8
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(psr/container) >= 1.0 with php-composer(psr/container) < 2)
@@ -140,9 +140,9 @@ sed -e '/listener/d' phpunit.xml.dist > phpunit.xml
RETURN_CODE=0
: Upstream tests with SCLs if available
-for SCL in php php72 php73 php74; do
+for SCL in php php72 php73 php74 php80; do
if which $SCL; then
- $SCL %{_bindir}/phpunit7 --verbose || RETURN_CODE=1
+ $SCL %{_bindir}/phpunit8 --verbose || RETURN_CODE=1
fi
done
exit $RETURN_CODE
@@ -160,6 +160,9 @@ exit $RETURN_CODE
%changelog
+* Mon Jul 6 2020 Remi Collet <remi@remirepo.net> - 3.0.4-1
+- update to 3.0.4
+
* Wed Feb 12 2020 Remi Collet <remi@remirepo.net> - 3.0.3-1
- update to 3.0.3