summaryrefslogtreecommitdiffstats
path: root/php-twig2.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-07-13 12:44:00 +0200
committerRemi Collet <remi@remirepo.net>2018-07-13 12:44:00 +0200
commit8af6d3652a869aee1aa87d79096ebcd8da8a722e (patch)
tree75aaafe3b99722f5af786a044012c13f09be4101 /php-twig2.spec
parentb2fd8c7e45606252f55c58008fa989cae4d09fc3 (diff)
update to 2.5.0
use phpunit6 for test suite
Diffstat (limited to 'php-twig2.spec')
-rw-r--r--php-twig2.spec20
1 files changed, 13 insertions, 7 deletions
diff --git a/php-twig2.spec b/php-twig2.spec
index cc4701a..68ce6d5 100644
--- a/php-twig2.spec
+++ b/php-twig2.spec
@@ -13,7 +13,7 @@
%global with_tests 0%{!?_without_tests:1}
%global github_owner twigphp
%global github_name Twig
-%global github_commit 7b604c89da162034bdf4bb66310f358d313dd16d
+%global github_commit 6a5f676b77a90823c2d4eaf76137b771adf31323
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global composer_vendor twig
@@ -24,12 +24,12 @@
%global phpdir %{_datadir}/php
Name: php-%{composer_project}2
-Version: 2.4.8
+Version: 2.5.0
Release: 1%{?dist}
Summary: The flexible, fast, and secure template engine for PHP
License: BSD
-URL: http://twig.sensiolabs.org
+URL: https://twig.symfony.com
Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{name}-%{version}-%{github_short}.tar.gz
BUildArch: noarch
@@ -38,7 +38,7 @@ BuildRequires: php-fedora-autoloader-devel
%if %{with_tests}
# For tests
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: php-composer(phpunit/phpunit)
+BuildRequires: phpunit6
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(symfony/debug) >= 2.7 with php-composer(symfony/debug) < 3)
@@ -49,6 +49,8 @@ BuildRequires: php-symfony-debug >= 2.7
BuildRequires: php-composer(psr/container) < 2
BuildRequires: php-composer(psr/container) >= 1.0
%endif
+# Workaround
+BuildRequires: php-symfony-common
## phpcompatinfo (computed from version 2.4.2)
BuildRequires: php-ctype
BuildRequires: php-date
@@ -64,7 +66,7 @@ BuildRequires: php-simplexml
## composer.json
Requires: php(language) >= %{php_min_ver}
-## phpcompatinfo (computed from version 2.4.2)
+## phpcompatinfo (computed from version 2.5.0)
Requires: php-ctype
Requires: php-date
Requires: php-hash
@@ -141,9 +143,9 @@ sed -e '/listener/d' phpunit.xml.dist > phpunit.xml
RETURN_CODE=0
: Upstream tests with SCLs if available
-for SCL in php php70 php71 php72; do
+for SCL in php php70 php71 php72 php73; do
if which $SCL; then
- $SCL %{_bindir}/phpunit --verbose || RETURN_CODE=1
+ $SCL %{_bindir}/phpunit6 --verbose || RETURN_CODE=1
fi
done
exit $RETURN_CODE
@@ -160,6 +162,10 @@ exit $RETURN_CODE
%changelog
+* Fri Jul 13 2018 Remi Collet <remi@remirepo.net> - 2.5.0-1
+- update to 2.5.0
+- use phpunit6 for test suite
+
* Tue Apr 3 2018 Remi Collet <remi@remirepo.net> - 2.4.8-1
- update to 2.4.8