summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION2
-rw-r--r--composer.json2
-rw-r--r--php-twig.spec14
3 files changed, 11 insertions, 7 deletions
diff --git a/REFLECTION b/REFLECTION
index 4c41044..54c4f09 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #72 twig version 1.28.1 ] {
+Extension [ <persistent> extension #72 twig version 1.28.2 ] {
- Functions {
Function [ <internal:twig> function twig_template_get_attributes ] {
diff --git a/composer.json b/composer.json
index 7de84b5..c0ff2e2 100644
--- a/composer.json
+++ b/composer.json
@@ -30,7 +30,7 @@
"php": ">=5.2.7"
},
"require-dev": {
- "symfony/phpunit-bridge": "~2.7",
+ "symfony/phpunit-bridge": "~3.2@dev",
"symfony/debug": "~2.7"
},
"autoload": {
diff --git a/php-twig.spec b/php-twig.spec
index cd64560..88c5a4e 100644
--- a/php-twig.spec
+++ b/php-twig.spec
@@ -30,8 +30,8 @@
%global github_owner twigphp
%global github_name Twig
-%global github_version 1.28.1
-%global github_commit fff80c4a7ae1d47a81dfec10c76cbcb939170b45
+%global github_version 1.28.2
+%global github_commit b22ce0eb070e41f7cba65d78fe216de29726459c
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%if "%{php_version}" < "7"
@@ -289,6 +289,8 @@ EXT_VERSION=`grep PHP_TWIG_VERSION ext/NTS/php_twig.h | awk '{print $3}' | sed '
sed -e 's/function testGetAttributeWithTemplateAsObject/function skip_testGetAttributeWithTemplateAsObject/' \
-i test/Twig/Tests/TemplateTest.php
%endif
+: Disable listener from symfony/phpunit-bridge 3.2@dev
+sed -e '/listener/d' phpunit.xml.dist > phpunit.xml
: Test suite without extension
# remirepo:11
@@ -303,17 +305,16 @@ if which php71; then
run=1
fi
if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --bootstrap %{buildroot}%{phpdir}/Twig/autoload.php --verbose
+%{_bindir}/phpunit --bootstrap %{buildroot}%{phpdir}/Twig/autoload.php --verbose || ret=1
# remirepo:1
fi
%if %{with_ext}
: Test suite with extension
%{_bindir}/php --define extension=ext/NTS/modules/%{ext_name}.so \
- %{_bindir}/phpunit --bootstrap %{buildroot}%{phpdir}/Twig/autoload.php --verbose
+ %{_bindir}/phpunit --bootstrap %{buildroot}%{phpdir}/Twig/autoload.php --verbose || ret=1
%endif
-# remirepo:1
exit $ret
%else
: Tests skipped
@@ -345,6 +346,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Nov 24 2016 Remi Collet <remi@fedoraproject.org> - 1.28.2-1
+- Update to 1.28.2
+
* Tue Nov 22 2016 Remi Collet <remi@fedoraproject.org> - 1.28.1-1
- Update to 1.28.1