summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-theseer-autoload.spec34
1 files changed, 24 insertions, 10 deletions
diff --git a/php-theseer-autoload.spec b/php-theseer-autoload.spec
index 1c04015..1c133dc 100644
--- a/php-theseer-autoload.spec
+++ b/php-theseer-autoload.spec
@@ -6,7 +6,11 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 784b31aaedbd0db069357ce8dae64ab70e3579ca
+
+# For compatibility with SCL
+%undefine __brp_mangle_shebangs
+
+%global gh_commit 771674385c0dbc0995769c85cc92e221a9da1bad
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner theseer
%global gh_project Autoload
@@ -15,11 +19,10 @@
%global pear_channel pear.netpirates.net
Name: php-theseer-autoload
-Version: 1.24.1
+Version: 1.25.0
Release: 1%{?dist}
Summary: A tool and library to generate autoload code
-Group: Development/Libraries
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
@@ -32,12 +35,14 @@ BuildRequires: php(language) >= 5.3.1
# From composer.json, "require-dev": {
# "phpunit/phpunit": "^4.8.35|^5.7|^6.0",
# "squizlabs/php_codesniffer": "~1.5"
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(theseer/directoryscanner) >= 1.3 with php-composer(theseer/directoryscanner) < 2)
+BuildRequires: (php-composer(zetacomponents/console-tools) >= 1.7 with php-composer(zetacomponents/console-tools) < 2)
+%global phpunit %{_bindir}/phpunit6
+%else
BuildRequires: php-composer(theseer/directoryscanner) >= 1.3
BuildRequires: php-composer(theseer/directoryscanner) < 2
BuildRequires: php-composer(zetacomponents/console-tools) >= 1.7
-%if 0%{?fedora} >= 26
-%global phpunit %{_bindir}/phpunit6
-%else
%global phpunit %{_bindir}/phpunit
%endif
BuildRequires: %{phpunit}
@@ -46,11 +51,16 @@ BuildRequires: %{phpunit}
# "theseer/directoryscanner": "~1.3",
# "zetacomponents/console-tools": "~1.7"
Requires: php(language) >= 5.3.1
-Requires: php-composer(theseer/directoryscanner) >= 1.3
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(theseer/directoryscanner) >= 1.3 with php-composer(theseer/directoryscanner) < 2)
+Requires: (php-composer(zetacomponents/console-tools) >= 1.7 with php-composer(zetacomponents/console-tools) < 2)
+%else
Requires: php-composer(theseer/directoryscanner) < 2
-Requires: php-composer(zetacomponents/console-tools) >= 1.7
+Requires: php-composer(theseer/directoryscanner) >= 1.3
Requires: php-composer(zetacomponents/console-tools) < 2
-# From phpcompatinfo report for version 1.21
+Requires: php-composer(zetacomponents/console-tools) >= 1.7
+%endif
+# From phpcompatinfo report for version 1.25.0
Requires: php-cli
Requires: php-date
Requires: php-json
@@ -110,7 +120,7 @@ class_exists('PHPUnit\Framework\TestCase') or class_alias('PHPUnit_Framework_Tes
EOF
ret=0
-for cmd in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmd in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72 php73; do
if which $cmd; then
set $cmd
$1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
@@ -135,6 +145,10 @@ fi
%changelog
+* Mon Jul 2 2018 Remi Collet <remi@remirepo.net> - 1.25.0-1
+- update to 1.25.0
+- use range dependencies
+
* Mon Jun 26 2017 Remi Collet <remi@remirepo.net> - 1.24.1-1
- Update to 1.24.1
- drop patch merged upstream