summaryrefslogtreecommitdiffstats
path: root/php-theseer-autoload.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-03-20 14:55:01 +0100
committerRemi Collet <remi@remirepo.net>2020-03-20 14:55:01 +0100
commitfb97c8c623bcf6af6c4c8c6b8c348a145d1dbeaf (patch)
treed2859eb19f825664664e3af75ae15070ef901f06 /php-theseer-autoload.spec
parent79b25aeb567c87cbd95e0d145d7d4115c199256b (diff)
v1.25.9
Diffstat (limited to 'php-theseer-autoload.spec')
-rw-r--r--php-theseer-autoload.spec20
1 files changed, 10 insertions, 10 deletions
diff --git a/php-theseer-autoload.spec b/php-theseer-autoload.spec
index fb86c6e..1059dc2 100644
--- a/php-theseer-autoload.spec
+++ b/php-theseer-autoload.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 7492afa5fa6724a4b136923a4aab2a713510ba68
+%global gh_commit 7b667d946d897770e3285e52bb85d3b1f0be21a3
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner theseer
%global gh_project Autoload
@@ -19,7 +19,7 @@
%global pear_channel pear.netpirates.net
Name: php-theseer-autoload
-Version: 1.25.8
+Version: 1.25.9
Release: 1%{?dist}
Summary: A tool and library to generate autoload code
@@ -32,13 +32,10 @@ Patch0: %{gh_project}-rpm.patch
BuildArch: noarch
BuildRequires: php(language) >= 5.3.1
-# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^4.8.35|^5.7|^6.0",
-# "squizlabs/php_codesniffer": "~1.5"
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(theseer/directoryscanner) >= 1.3 with php-composer(theseer/directoryscanner) < 2)
BuildRequires: (php-composer(zetacomponents/console-tools) >= 1.7 with php-composer(zetacomponents/console-tools) < 2)
-%global phpunit %{_bindir}/phpunit6
+%global phpunit %{_bindir}/phpunit7
%else
BuildRequires: php-composer(theseer/directoryscanner) < 2
BuildRequires: php-composer(theseer/directoryscanner) >= 1.3
@@ -49,8 +46,8 @@ BuildRequires: php-composer(zetacomponents/console-tools) >= 1.7
BuildRequires: %{phpunit}
# From composer.json, "require": {
-# "theseer/directoryscanner": "~1.3",
-# "zetacomponents/console-tools": "~1.7"
+# "theseer/directoryscanner": "^1.3",
+# "zetacomponents/console-tools": "^1.7.1"
Requires: php(language) >= 5.3.1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(theseer/directoryscanner) >= 1.3 with php-composer(theseer/directoryscanner) < 2)
@@ -126,10 +123,10 @@ class_exists('PHPUnit\Framework\TestCase') or class_alias('PHPUnit_Framework_Tes
EOF
ret=0
-for cmd in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72 php73 php74; do
+for cmd in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" php71 php72 php73 php74; do
if which $cmd; then
set $cmd
- $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
fi
done
exit $ret
@@ -151,6 +148,9 @@ fi
%changelog
+* Fri Mar 20 2020 Remi Collet <remi@remirepo.net> - 1.25.9-1
+- update to 1.25.9
+
* Mon Nov 25 2019 Remi Collet <remi@remirepo.net> - 1.25.8-1
- update to 1.25.8