summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-tedivm-jshrink.spec18
2 files changed, 12 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 9483d5e..bda07fc 100644
--- a/composer.json
+++ b/composer.json
@@ -12,7 +12,7 @@
}
],
"require": {
- "php": "^5.6|^7.0"
+ "php": "^5.6|^7.0|^8.0"
},
"require-dev": {
"phpunit/phpunit": "^6",
diff --git a/php-tedivm-jshrink.spec b/php-tedivm-jshrink.spec
index 4399d33..ba8c5e8 100644
--- a/php-tedivm-jshrink.spec
+++ b/php-tedivm-jshrink.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-tedivm-jshrink
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -8,7 +8,7 @@
#
%bcond_without tests
-%global gh_commit 566e0c731ba4e372be2de429ef7d54f4faf4477a
+%global gh_commit 0513ba1407b1f235518a939455855e6952a48bbc
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner tedious
#global gh_date 20150820
@@ -18,7 +18,7 @@
%global psr0 JShrink
Name: php-%{c_vendor}-%{c_project}
-Version: 1.3.3
+Version: 1.4.0
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: Javascript Minifier built in PHP
@@ -37,13 +37,13 @@ BuildRequires: php-spl
# "phpunit/phpunit": "^6",
# "friendsofphp/php-cs-fixer": "^2.8",
# "php-coveralls/php-coveralls": "^1.1.0"
-BuildRequires: phpunit6
+BuildRequires: phpunit7
%endif
# For autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": "^5.6|^7.0"
+# "php": "^5.6|^7.0|^8.0"
Requires: php(language) >= 5.6.0
# From phpcompatinfo report for 1.1.0
Requires: php-date
@@ -90,9 +90,9 @@ EOF
: Run upstream test suite
ret=0
-for cmd in php php72 php73 php74 php80; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
- $cmd %{_bindir}/phpunit6 \
+ $cmd %{_bindir}/phpunit7 \
--no-coverage \
--verbose || ret=1
fi
@@ -113,6 +113,10 @@ exit $ret
%changelog
+* Thu Apr 1 2021 Remi Collet <remi@remirepo.net> - 1.4.0-1
+- update to 1.4.0
+- switch to phpunit7
+
* Mon Sep 7 2020 Remi Collet <remi@remirepo.net> - 1.3.3-1
- update to 1.3.3
- raise dependency on PHP 5.6