summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--51.patch31
-rw-r--r--php-tecnickcom-tc-lib-barcode.spec15
2 files changed, 43 insertions, 3 deletions
diff --git a/51.patch b/51.patch
new file mode 100644
index 0000000..6b87e67
--- /dev/null
+++ b/51.patch
@@ -0,0 +1,31 @@
+From 7c1c7693ca684c778d59a35accec6622f9879877 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Thu, 2 Jan 2020 14:10:52 +0100
+Subject: [PATCH] skip non hexa char. for 7.4
+
+---
+ src/Type/Linear/MsiCheck.php | 11 +++++++----
+ 1 file changed, 7 insertions(+), 4 deletions(-)
+
+diff --git a/src/Type/Linear/MsiCheck.php b/src/Type/Linear/MsiCheck.php
+index f658f90..9725fa9 100644
+--- a/src/Type/Linear/MsiCheck.php
++++ b/src/Type/Linear/MsiCheck.php
+@@ -77,10 +77,13 @@ protected function getChecksum($code)
+ $pix = 2;
+ $check = 0;
+ for ($pos = ($clen - 1); $pos >= 0; --$pos) {
+- $check += (hexdec($code[$pos]) * $pix);
+- ++$pix;
+- if ($pix > 7) {
+- $pix = 2;
++ $t = $code[$pos];
++ if ($t >= "0" && $t <= "9" || $t >= "a" && $t <= "f" || $t >= "A" && $t <= "F") {
++ $check += (hexdec($t) * $pix);
++ ++$pix;
++ if ($pix > 7) {
++ $pix = 2;
++ }
+ }
+ }
+ $check %= 11;
diff --git a/php-tecnickcom-tc-lib-barcode.spec b/php-tecnickcom-tc-lib-barcode.spec
index edf05c0..646099a 100644
--- a/php-tecnickcom-tc-lib-barcode.spec
+++ b/php-tecnickcom-tc-lib-barcode.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-tecnickcom-tc-lib-barcode
#
-# Copyright (c) 2015-2019 Remi Collet
+# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 60780acd7aeaca3547b16963dda3f09c6bdce2e7
+%global gh_commit 853b29c4369b368e2c890084184bc4420b7707b8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.15.16
+Version: 1.15.18
Release: 1%{?dist}
Summary: PHP library to generate linear and bidimensional barcodes
@@ -23,6 +23,8 @@ License: LGPLv3+
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
+Patch0: https://patch-diff.githubusercontent.com/raw/tecnickcom/tc-lib-barcode/pull/51.patch
+
BuildArch: noarch
%if %{with_tests}
# For tests
@@ -90,6 +92,8 @@ Optional dependency: php-pecl-imagick
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1 -b .pr51
+
: Sanity check
grep -q '^%{version}$' VERSION
@@ -142,6 +146,11 @@ exit $ret
%changelog
+* Thu Jan 2 2020 Remi Collet <remi@remirepo.net> - 1.15.18-1
+- update to 1.15.18
+- add patch for 7.4 from
+ https://github.com/tecnickcom/tc-lib-barcode/pull/51
+
* Wed Oct 2 2019 Remi Collet <remi@remirepo.net> - 1.15.16-1
- update to 1.15.16