summaryrefslogtreecommitdiffstats
path: root/php-symfony4.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-01 10:00:32 +0200
committerRemi Collet <remi@remirepo.net>2021-06-01 10:00:32 +0200
commit5b390ca68b7cf69b7cedf3f954711ab3b95f93de (patch)
treeff0db3dae738c3e4bcb6cc145885bd0ff16499e0 /php-symfony4.spec
parentc113dd4e2d060a57d8790fd8cfe11432b188a244 (diff)
update to 4.4.25
add dependency on symfony/polyfill-php81
Diffstat (limited to 'php-symfony4.spec')
-rw-r--r--php-symfony4.spec17
1 files changed, 14 insertions, 3 deletions
diff --git a/php-symfony4.spec b/php-symfony4.spec
index 3d6829d..769f055 100644
--- a/php-symfony4.spec
+++ b/php-symfony4.spec
@@ -13,8 +13,8 @@
%global github_owner symfony
%global github_name symfony
-%global github_version 4.4.24
-%global github_commit 854af7600a6249c34bdbf4120e078aef6ece660e
+%global github_version 4.4.25
+%global github_commit c71e9ba222f7a970e92399c1fb5d82af18c77dd4
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global composer_vendor symfony
@@ -94,7 +94,8 @@
# "symfony/polyfill-php72": "~1.5"
# "symfony/polyfill-php73": "~1.11"
# "symfony/polyfill-php80": "^1.15"
-%global symfony_polyfill_min_ver 1.15
+# "symfony/polyfill-php81": "^1.22"
+%global symfony_polyfill_min_ver 1.22
%global symfony_polyfill_max_ver 2.0
# "symfony/security-acl": "~2.8|~3.0"
%global symfony_security_acl_min_ver 2.8
@@ -913,6 +914,12 @@ URL: http://symfony.com/doc/%{symfony4_doc_ver}/components/config.html
# composer.json
Requires: php-composer(%{composer_vendor}/filesystem) = %{version}
+%if %{with_range_dependencies}
+Requires:(php-composer(%{composer_vendor}/polyfill-php81) >= %{symfony_polyfill_min_ver} with php-composer(%{composer_vendor}/polyfill-php81) < %{symfony_polyfill_max_ver})
+%else
+Requires: php-composer(%{composer_vendor}/polyfill-php81) < %{symfony_polyfill_max_ver}
+Requires: php-composer(%{composer_vendor}/polyfill-php81) >= %{symfony_polyfill_min_ver}
+%endif
# composer.json: optional
%if %{with_range_dependencies}
Suggests: php-composer(%{composer_vendor}/yaml)
@@ -3303,6 +3310,10 @@ exit $RET
# ##############################################################################
%changelog
+* Tue Jun 1 2021 Remi Collet <remi@remirepo.net> - 4.4.25-1
+- update to 4.4.25
+- add dependency on symfony/polyfill-php81
+
* Wed May 19 2021 Remi Collet <remi@remirepo.net> - 4.4.24-1
- update to 4.4.24