summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-07-24 11:52:18 +0200
committerRemi Collet <remi@remirepo.net>2020-07-24 11:52:18 +0200
commit4eda95ecfac1e09058276c0688ce2029fdfa8652 (patch)
tree9b90f95e7f2cf101538dd9013ab7fe43049142ab
parent0d8d76bb69351764992c0f5e694cee53783d2636 (diff)
update to 4.4.11HEADmaster
raise dependency on doctrine/data-fixtures 1.1 allow doctrine/persistence 2 allow phpdocumentor/reflection-docblock 5
-rw-r--r--composer.json7
-rwxr-xr-xphp-symfony4-generate-autoloaders.php7
-rw-r--r--php-symfony4.spec28
-rw-r--r--src/Symfony/Bridge/Doctrine/composer.json5
-rw-r--r--src/Symfony/Component/Asset/composer.json2
-rw-r--r--src/Symfony/Component/CssSelector/composer.json2
-rw-r--r--src/Symfony/Component/Dotenv/composer.json2
-rw-r--r--src/Symfony/Component/Finder/composer.json2
-rw-r--r--src/Symfony/Component/Form/composer.json2
-rw-r--r--src/Symfony/Component/Messenger/composer.json2
-rw-r--r--src/Symfony/Component/OptionsResolver/composer.json2
-rw-r--r--src/Symfony/Component/Process/composer.json2
-rw-r--r--src/Symfony/Component/PropertyInfo/composer.json2
-rw-r--r--src/Symfony/Component/Routing/composer.json2
-rw-r--r--src/Symfony/Component/VarExporter/composer.json2
15 files changed, 40 insertions, 29 deletions
diff --git a/composer.json b/composer.json
index 5ad1c5c..2af8cf7 100644
--- a/composer.json
+++ b/composer.json
@@ -19,7 +19,7 @@
"php": ">=7.1.3",
"ext-xml": "*",
"doctrine/event-manager": "~1.0",
- "doctrine/persistence": "^1.3",
+ "doctrine/persistence": "^1.3|^2",
"twig/twig": "^1.41|^2.10|^3.0",
"psr/cache": "~1.0",
"psr/container": "^1.0",
@@ -100,10 +100,11 @@
},
"require-dev": {
"cache/integration-tests": "dev-master",
+ "composer/package-versions-deprecated": "^1.8",
"doctrine/annotations": "~1.0",
"doctrine/cache": "~1.6",
"doctrine/collections": "~1.0",
- "doctrine/data-fixtures": "1.0.*",
+ "doctrine/data-fixtures": "^1.1",
"doctrine/dbal": "~2.4",
"doctrine/orm": "~2.4,>=2.4.5",
"doctrine/reflection": "~1.0",
@@ -121,7 +122,7 @@
"egulias/email-validator": "~1.2,>=1.2.8|~2.0",
"symfony/phpunit-bridge": "^5.0.8",
"symfony/security-acl": "~2.8|~3.0",
- "phpdocumentor/reflection-docblock": "^3.0|^4.0",
+ "phpdocumentor/reflection-docblock": "^3.0|^4.0|^5.0",
"twig/cssinliner-extra": "^2.12",
"twig/inky-extra": "^2.12",
"twig/markdown-extra": "^2.12"
diff --git a/php-symfony4-generate-autoloaders.php b/php-symfony4-generate-autoloaders.php
index a566449..8d10691 100755
--- a/php-symfony4-generate-autoloaders.php
+++ b/php-symfony4-generate-autoloaders.php
@@ -35,6 +35,7 @@ final class AutoloadGenerator {
'prefix' => 'FEDORA_SYMFONY4_PHP_DIR',
'path' => 'Cache/IntegrationTests/autoload.php',
],
+ 'composer/package-versions-deprecated' => false,
'doctrine/annotations' => [
'prefix' => 'FEDORA_SYMFONY4_PHP_DIR',
'path' => 'Doctrine/Common/Annotations/autoload.php',
@@ -57,7 +58,10 @@ final class AutoloadGenerator {
],
'doctrine/persistence' => [
'prefix' => 'FEDORA_SYMFONY4_PHP_DIR',
- 'path' => 'Doctrine/Common/Persistence/autoload.php',
+ 'path' => [
+ 'Doctrine/Common/Persistence2/autoload.php',
+ 'Doctrine/Common/Persistence/autoload.php',
+ ],
],
'doctrine/reflection' => [
'prefix' => 'FEDORA_SYMFONY4_PHP_DIR',
@@ -113,6 +117,7 @@ final class AutoloadGenerator {
'phpdocumentor/reflection-docblock' => [
'prefix' => 'FEDORA_SYMFONY4_PHP_DIR',
'path' => [
+ 'phpDocumentor/Reflection/DocBlock5/autoload.php',
'phpDocumentor/Reflection/DocBlock4/autoload.php',
'phpDocumentor/Reflection/DocBlock/autoload.php',
],
diff --git a/php-symfony4.spec b/php-symfony4.spec
index 09d7f1b..9d20663 100644
--- a/php-symfony4.spec
+++ b/php-symfony4.spec
@@ -13,8 +13,8 @@
%global github_owner symfony
%global github_name symfony
-%global github_version 4.4.10
-%global github_commit 7eef70427b37763aebfe4ba8aa33e052f91fee3f
+%global github_version 4.4.11
+%global github_commit f5721c658ea5752000baca99f07cc0554708b56f
%global composer_vendor symfony
%global composer_project symfony
@@ -37,15 +37,15 @@
# "doctrine/event-manager": "~1.0"
%global doctrine_event_manager_min_ver 1.0
%global doctrine_event_manager_max_ver 2
-# "doctrine/persistence": "^1.3"
+# "doctrine/persistence": "^1.3|^2"
%global doctrine_persistence_min_ver 1.3
-%global doctrine_persistence_max_ver 2
+%global doctrine_persistence_max_ver 3
# "doctrine/reflection": "~1.0"
%global doctrine_reflection_min_ver 1.0
%global doctrine_reflection_max_ver 2
-# "doctrine/data-fixtures": "1.0.*"
+# "doctrine/data-fixtures": "^1.1"
# ignore max version
-%global doctrine_datafixtures_min_ver 1.0.0
+%global doctrine_datafixtures_min_ver 1.1
%global doctrine_datafixtures_max_ver 2
# "doctrine/dbal": "^2.5|^3.0"
# ignore 3.0 for now, no yet packaged
@@ -69,10 +69,10 @@
# "ocramius/proxy-manager": "~2.1"
%global proxy_manager_min_ver 2.1
%global proxy_manager_max_ver 3.0
-# "phpdocumentor/reflection-docblock": "^3.0|^4.0"
+# "phpdocumentor/reflection-docblock": "^3.0|^4.0|^5.0"
# conflicts: "phpdocumentor/reflection-docblock": "<3.0||>=3.2.0,<3.2.2"
%global phpdocumentor_reflection_docblock_min_ver 3.2.2
-%global phpdocumentor_reflection_docblock_max_ver 5.0
+%global phpdocumentor_reflection_docblock_max_ver 6
# "psr/cache": "~1.0"
%global psr_cache_min_ver 1.0
%global psr_cache_max_ver 2.0
@@ -224,8 +224,7 @@ BuildRequires: php-composer(masterminds/html5) < %{masterminds_max_ver}
BuildRequires: php-composer(masterminds/html5) >= %{masterminds_min_ver}
BuildRequires: php-composer(mongodb/mongodb) < %{mongodb_max_ver}
BuildRequires: php-composer(mongodb/mongodb) >= %{mongodb_min_ver}
-BuildRequires: php-composer(monolog/monolog) < %{monolog_max_ver}
-BuildRequires: php-composer(monolog/monolog) >= %{monolog_min_ver}
+BuildRequires: php-Monolog >= %{monolog_min_ver}
BuildRequires: php-composer(nyholm/psr7) < %{nyholm_psr7_max_ver}
BuildRequires: php-composer(nyholm/psr7) >= %{nyholm_psr7_min_ver}
BuildRequires: php-composer(ocramius/proxy-manager) < %{proxy_manager_max_ver}
@@ -440,8 +439,7 @@ Suggests: php-composer(%{composer_vendor}/console)
Suggests: php-composer(%{composer_vendor}/security-core)
Suggests: php-composer(%{composer_vendor}/var-dumper)
%else
-Requires: php-composer(monolog/monolog) >= %{monolog_min_ver}
-Requires: php-composer(monolog/monolog) < %{monolog_max_ver}
+Requires: php-Monolog >= %{monolog_min_ver}
Requires: php-composer(%{composer_vendor}/service-contracts) < %{symfony_contracts_max_ver}
Requires: php-composer(%{composer_vendor}/service-contracts) >= %{symfony_contracts_min_ver}
%endif
@@ -3295,6 +3293,12 @@ exit $RET
# ##############################################################################
%changelog
+* Fri Jul 24 2020 Remi Collet <remi@remirepo.net> - 4.4.11-1
+- update to 4.4.11
+- raise dependency on doctrine/data-fixtures 1.1
+- allow doctrine/persistence 2
+- allow phpdocumentor/reflection-docblock 5
+
* Mon Jun 15 2020 Remi Collet <remi@remirepo.net> - 4.4.10-1
- update to 4.4.10
diff --git a/src/Symfony/Bridge/Doctrine/composer.json b/src/Symfony/Bridge/Doctrine/composer.json
index fde197d..4194aa2 100644
--- a/src/Symfony/Bridge/Doctrine/composer.json
+++ b/src/Symfony/Bridge/Doctrine/composer.json
@@ -18,12 +18,13 @@
"require": {
"php": ">=7.1.3",
"doctrine/event-manager": "~1.0",
- "doctrine/persistence": "^1.3",
+ "doctrine/persistence": "^1.3|^2",
"symfony/polyfill-ctype": "~1.8",
"symfony/polyfill-mbstring": "~1.0",
"symfony/service-contracts": "^1.1|^2"
},
"require-dev": {
+ "composer/package-versions-deprecated": "^1.8",
"symfony/stopwatch": "^3.4|^4.0|^5.0",
"symfony/config": "^4.2|^5.0",
"symfony/dependency-injection": "^3.4|^4.0|^5.0",
@@ -41,7 +42,7 @@
"doctrine/annotations": "~1.7",
"doctrine/cache": "~1.6",
"doctrine/collections": "~1.0",
- "doctrine/data-fixtures": "1.0.*",
+ "doctrine/data-fixtures": "^1.1",
"doctrine/dbal": "~2.4",
"doctrine/orm": "^2.6.3",
"doctrine/reflection": "~1.0"
diff --git a/src/Symfony/Component/Asset/composer.json b/src/Symfony/Component/Asset/composer.json
index fc12a5b..04f26f6 100644
--- a/src/Symfony/Component/Asset/composer.json
+++ b/src/Symfony/Component/Asset/composer.json
@@ -16,7 +16,7 @@
}
],
"require": {
- "php": "^7.1.3"
+ "php": ">=7.1.3"
},
"suggest": {
"symfony/http-foundation": ""
diff --git a/src/Symfony/Component/CssSelector/composer.json b/src/Symfony/Component/CssSelector/composer.json
index 65642dc..b9fcb72 100644
--- a/src/Symfony/Component/CssSelector/composer.json
+++ b/src/Symfony/Component/CssSelector/composer.json
@@ -20,7 +20,7 @@
}
],
"require": {
- "php": "^7.1.3"
+ "php": ">=7.1.3"
},
"autoload": {
"psr-4": { "Symfony\\Component\\CssSelector\\": "" },
diff --git a/src/Symfony/Component/Dotenv/composer.json b/src/Symfony/Component/Dotenv/composer.json
index 5520f45..ec04c16 100644
--- a/src/Symfony/Component/Dotenv/composer.json
+++ b/src/Symfony/Component/Dotenv/composer.json
@@ -16,7 +16,7 @@
}
],
"require": {
- "php": "^7.1.3"
+ "php": ">=7.1.3"
},
"require-dev": {
"symfony/process": "^3.4.2|^4.0|^5.0"
diff --git a/src/Symfony/Component/Finder/composer.json b/src/Symfony/Component/Finder/composer.json
index 0b1408c..8ab56ea 100644
--- a/src/Symfony/Component/Finder/composer.json
+++ b/src/Symfony/Component/Finder/composer.json
@@ -16,7 +16,7 @@
}
],
"require": {
- "php": "^7.1.3"
+ "php": ">=7.1.3"
},
"autoload": {
"psr-4": { "Symfony\\Component\\Finder\\": "" },
diff --git a/src/Symfony/Component/Form/composer.json b/src/Symfony/Component/Form/composer.json
index 283fff0..51bbdba 100644
--- a/src/Symfony/Component/Form/composer.json
+++ b/src/Symfony/Component/Form/composer.json
@@ -22,7 +22,7 @@
"symfony/options-resolver": "~4.3|^5.0",
"symfony/polyfill-ctype": "~1.8",
"symfony/polyfill-mbstring": "~1.0",
- "symfony/property-access": "^3.4|^4.0|^5.0",
+ "symfony/property-access": "^3.4.40|^4.4.8|^5.0.8",
"symfony/service-contracts": "^1.1|^2"
},
"require-dev": {
diff --git a/src/Symfony/Component/Messenger/composer.json b/src/Symfony/Component/Messenger/composer.json
index bbc5e5e..877049a 100644
--- a/src/Symfony/Component/Messenger/composer.json
+++ b/src/Symfony/Component/Messenger/composer.json
@@ -22,8 +22,8 @@
},
"require-dev": {
"doctrine/dbal": "^2.6|^3.0",
+ "doctrine/persistence": "^1.3|^2",
"psr/cache": "~1.0",
- "doctrine/persistence": "^1.3",
"symfony/console": "^3.4|^4.0|^5.0",
"symfony/dependency-injection": "^3.4.19|^4.1.8|^5.0",
"symfony/event-dispatcher": "^4.3|^5.0",
diff --git a/src/Symfony/Component/OptionsResolver/composer.json b/src/Symfony/Component/OptionsResolver/composer.json
index d9a237e..e5721c6 100644
--- a/src/Symfony/Component/OptionsResolver/composer.json
+++ b/src/Symfony/Component/OptionsResolver/composer.json
@@ -16,7 +16,7 @@
}
],
"require": {
- "php": "^7.1.3"
+ "php": ">=7.1.3"
},
"autoload": {
"psr-4": { "Symfony\\Component\\OptionsResolver\\": "" },
diff --git a/src/Symfony/Component/Process/composer.json b/src/Symfony/Component/Process/composer.json
index e0174de..4a7d8f4 100644
--- a/src/Symfony/Component/Process/composer.json
+++ b/src/Symfony/Component/Process/composer.json
@@ -16,7 +16,7 @@
}
],
"require": {
- "php": "^7.1.3"
+ "php": ">=7.1.3"
},
"autoload": {
"psr-4": { "Symfony\\Component\\Process\\": "" },
diff --git a/src/Symfony/Component/PropertyInfo/composer.json b/src/Symfony/Component/PropertyInfo/composer.json
index fa24113..f9f97e8 100644
--- a/src/Symfony/Component/PropertyInfo/composer.json
+++ b/src/Symfony/Component/PropertyInfo/composer.json
@@ -30,7 +30,7 @@
"symfony/serializer": "^3.4|^4.0|^5.0",
"symfony/cache": "^3.4|^4.0|^5.0",
"symfony/dependency-injection": "^3.4|^4.0|^5.0",
- "phpdocumentor/reflection-docblock": "^3.0|^4.0",
+ "phpdocumentor/reflection-docblock": "^3.0|^4.0|^5.0",
"doctrine/annotations": "~1.7"
},
"conflict": {
diff --git a/src/Symfony/Component/Routing/composer.json b/src/Symfony/Component/Routing/composer.json
index 21fe8ee..73b2ae9 100644
--- a/src/Symfony/Component/Routing/composer.json
+++ b/src/Symfony/Component/Routing/composer.json
@@ -16,7 +16,7 @@
}
],
"require": {
- "php": "^7.1.3"
+ "php": ">=7.1.3"
},
"require-dev": {
"symfony/config": "^4.2|^5.0",
diff --git a/src/Symfony/Component/VarExporter/composer.json b/src/Symfony/Component/VarExporter/composer.json
index f589cde..7d4570c 100644
--- a/src/Symfony/Component/VarExporter/composer.json
+++ b/src/Symfony/Component/VarExporter/composer.json
@@ -16,7 +16,7 @@
}
],
"require": {
- "php": "^7.1.3"
+ "php": ">=7.1.3"
},
"require-dev": {
"symfony/var-dumper": "^4.4.9|^5.0.9"