summaryrefslogtreecommitdiffstats
path: root/php-symfony3.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-19 07:48:03 +0200
committerRemi Collet <remi@remirepo.net>2017-08-19 07:48:03 +0200
commit13761a01dc4aeccde3cab1284805f77fe22de539 (patch)
tree4e1db497e16879f0300143fc2842cdb8dba99de0 /php-symfony3.spec
parenta60bb925973362dc4dfe805e256a76363fcfa4e1 (diff)
sync with fedora
Diffstat (limited to 'php-symfony3.spec')
-rw-r--r--php-symfony3.spec32
1 files changed, 15 insertions, 17 deletions
diff --git a/php-symfony3.spec b/php-symfony3.spec
index f0155b2..8f62142 100644
--- a/php-symfony3.spec
+++ b/php-symfony3.spec
@@ -120,7 +120,7 @@
Name: php-%{composer_project}3
Version: %{github_version}
-Release: 2%{?dist}
+Release: 3%{?dist}
Summary: Symfony PHP framework (version 3)
Group: Development/Libraries
@@ -2038,13 +2038,6 @@ if (in_array(basename('$PKG'), [
require_once '%{phpdir}/Psr/Log/autoload.php';
}
-// Missing in require-dev (use Error class from PHP 7)
-if (in_array(basename('$PKG'), [
- 'Console',
-])) {
- require_once '%{phpdir}/Symfony/Polyfill/autoload.php';
-}
-
// For cache component's require-dev.
if ('Cache' == basename('$PKG')) {
require_once '%{phpdir}/Cache/IntegrationTests/autoload.php';
@@ -2052,18 +2045,20 @@ if ('Cache' == basename('$PKG')) {
require_once '%{phpdir}/Doctrine/DBAL/autoload.php';
}
-// For workflow component's require-dev.
-if ('Workflow' == basename('$PKG')) {
- require_once '%{phpdir}/Psr/Cache/autoload.php';
+// For console component's (undocumented) require-dev.
+// See https://github.com/symfony/symfony/pull/23934
+if ('Console' == basename('$PKG')) {
+ require_once '%{phpdir}/Symfony/Polyfill/autoload.php';
}
-// Missing
+// For vardumper component's require-dev.
if ('VarDumper' == basename('$PKG')) {
- if (file_exists('%{phpdir}/Twig/autoload.php')) {
- require_once '%{phpdir}/Twig/autoload.php';
- } else {
- require_once '%{phpdir}/Twig2/autoload.php';
- }
+ require_once file_exists('%{phpdir}/Twig2/autoload.php') ? '%{phpdir}/Twig2/autoload.php' : '%{phpdir}/Twig/autoload.php';
+}
+
+// For workflow component's require-dev.
+if ('Workflow' == basename('$PKG')) {
+ require_once '%{phpdir}/Psr/Cache/autoload.php';
}
BOOTSTRAP
@@ -2820,6 +2815,9 @@ exit $RET
# ##############################################################################
%changelog
+* Fri Aug 18 2017 Shawn Iwinski <shawn@iwin.ski> - 3.3.6-3
+- Fix some tests' dev requires (thanks Remi!)
+
* Mon Aug 14 2017 Shawn Iwinski <shawn@iwin.ski> - 3.3.6-2
- Fix dotenv sub-package Composer provide