summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-12-12 11:05:13 +0100
committerRemi Collet <remi@remirepo.net>2019-12-12 11:05:13 +0100
commit989265e3f8856b8b9ddb5e8a74fc4fd0ede7159c (patch)
treef6ac228774fda8affa6a57d7f21c27a685e8cc60
parentea9718869a37e7037b3cbac13012215e48bf62d8 (diff)
use range dependencies
-rw-r--r--php-symfony-security-acl.spec22
1 files changed, 18 insertions, 4 deletions
diff --git a/php-symfony-security-acl.spec b/php-symfony-security-acl.spec
index 6e5f86f..2a8f985 100644
--- a/php-symfony-security-acl.spec
+++ b/php-symfony-security-acl.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-symfony-securiy-acl
#
-# Copyright (c) 2016 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2016-2019 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -51,7 +51,7 @@
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 4%{?github_release}%{?dist}
+Release: 9%{?github_release}%{?dist}
Summary: Symfony Security Component - ACL (Access Control List)
Group: Development/Libraries
@@ -64,15 +64,22 @@ BuildArch: noarch
%if %{with_tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires:(php-composer(doctrine/common) >= %{doctrine_common_min_ver} with php-composer(doctrine/common) < %{doctrine_common_max_ver})
+BuildRequires:(php-composer(doctrine/dbal) >= %{doctrine_dbal_min_ver} with php-composer(doctrine/dbal) < %{doctrine_dbal_max_ver})
+BuildRequires:(php-composer(psr/log) >= %{psr_log_min_ver} with php-composer(psr/log) < %{psr_log_max_ver})
+BuildRequires:(php-composer(symfony/security-core) >= %{symfony_min_ver} with php-composer(symfony/security-core) < %{symfony_max_ver})
+%else
BuildRequires: php-composer(doctrine/common) < %{doctrine_common_max_ver}
BuildRequires: php-composer(doctrine/common) >= %{doctrine_common_min_ver}
BuildRequires: php-composer(doctrine/dbal) < %{doctrine_dbal_max_ver}
BuildRequires: php-composer(doctrine/dbal) >= %{doctrine_dbal_min_ver}
-BuildRequires: php-composer(phpunit/phpunit)
BuildRequires: php-composer(psr/log) < %{psr_log_max_ver}
BuildRequires: php-composer(psr/log) >= %{psr_log_min_ver}
BuildRequires: php-composer(symfony/security-core) < %{symfony_max_ver}
BuildRequires: php-composer(symfony/security-core) >= %{symfony_min_ver}
+%endif
+BuildRequires: php-composer(phpunit/phpunit)
## phpcompatinfo (computed from version 2.8.0)
BuildRequires: php-pcre
BuildRequires: php-reflection
@@ -83,8 +90,12 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(symfony/security-core) >= %{symfony_min_ver} with php-composer(symfony/security-core) < %{symfony_max_ver})
+%else
Requires: php-composer(symfony/security-core) < %{symfony_max_ver}
Requires: php-composer(symfony/security-core) >= %{symfony_min_ver}
+%endif
# phpcompatinfo (computed from version 2.8.0)
Requires: php-pcre
Requires: php-reflection
@@ -165,7 +176,7 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" %{?rhel:php54 php55} php56 php70 php71 php72; do
+for PHP_EXEC in "" %{?rhel:php54 php55 php56 php70} php71 php72 php73 php74; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php || RETURN_CODE=1
fi
@@ -190,6 +201,9 @@ exit $RETURN_CODE
%changelog
+* Thu Dec 12 2019 Remi Collet <remi@remirepo.net> - 2.8.0-9
+- use range dependencies
+
* Thu Sep 21 2017 Shawn Iwinski <shawn@iwin.ski> - 2.8.0-4
- Add max versions to BuildRequires
- Switch autoloader to fedora/autoloader