summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-05-31 14:32:16 +0200
committerRemi Collet <fedora@famillecollet.com>2016-05-31 14:32:16 +0200
commitb15ef768fe714ba5b760498f40f9edfbd038872a (patch)
tree41fc7c6eed1537a21146232367bd31bc1ee36fe3
parentd92b83fcbae48e19e65a9d5f97a87a3d17f1af15 (diff)
php-symfony-security-acl: add backport stuff
-rw-r--r--Makefile6
-rw-r--r--composer.json45
-rw-r--r--php-symfony-security-acl.spec20
3 files changed, 71 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..3af85b3
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,6 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
+diff:
+ colordiff --ignore-blank-lines -I 'Group:' -I 'defattr' -u /work/fedora/php-symfony/*spec *spec \ No newline at end of file
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..cd0fab5
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,45 @@
+{
+ "name": "symfony/security-acl",
+ "type": "library",
+ "description": "Symfony Security Component - ACL (Access Control List)",
+ "keywords": [],
+ "homepage": "https://symfony.com",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Fabien Potencier",
+ "email": "fabien@symfony.com"
+ },
+ {
+ "name": "Symfony Community",
+ "homepage": "https://symfony.com/contributors"
+ }
+ ],
+ "require": {
+ "php": ">=5.3.9",
+ "symfony/security-core": "~2.4|~3.0.0"
+ },
+ "require-dev": {
+ "symfony/phpunit-bridge": "~2.7|~3.0.0",
+ "doctrine/common": "~2.2",
+ "doctrine/dbal": "~2.2",
+ "psr/log": "~1.0"
+ },
+ "suggest": {
+ "symfony/class-loader": "For using the ACL generateSql script",
+ "symfony/finder": "For using the ACL generateSql script",
+ "doctrine/dbal": "For using the built-in ACL implementation"
+ },
+ "autoload": {
+ "psr-4": { "Symfony\\Component\\Security\\Acl\\": "" },
+ "exclude-from-classmap": [
+ "/Tests/"
+ ]
+ },
+ "minimum-stability": "dev",
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.8-dev"
+ }
+ }
+}
diff --git a/php-symfony-security-acl.spec b/php-symfony-security-acl.spec
index 5b69491..7a0c1b1 100644
--- a/php-symfony-security-acl.spec
+++ b/php-symfony-security-acl.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-symfony-securiy-acl, from:
#
# Fedora spec file for php-symfony-securiy-acl
#
@@ -58,6 +59,7 @@ URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
BuildArch: noarch
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
# Tests
%if %{with_tests}
## composer.json
@@ -88,10 +90,14 @@ Requires: php-spl
Requires: php-composer(symfony/class-loader)
# Weak dependencies
+%if 0%{?fedora} >= 21
Suggests: php-composer(doctrine/dbal)
+%endif
Conflicts: php-doctrine-dbal < %{doctrine_dbal_min_ver}
Conflicts: php-doctrine-dbal >= %{doctrine_dbal_max_ver}
+%if 0%{?fedora} >= 21
Suggests: php-composer(symfony/finder)
+%endif
Conflicts: php-symfony-finder < %{symfony_min_ver}
Conflicts: php-symfony-finder >= %{symfony_max_ver}
@@ -149,6 +155,8 @@ AUTOLOAD
%install
+rm -rf %{buildroot}
+
mkdir -p %{buildroot}%{phpdir}/Symfony/Component/Security/Acl
cp -rp * %{buildroot}%{phpdir}/Symfony/Component/Security/Acl/
@@ -165,12 +173,21 @@ require_once '%{phpdir}/Psr/Log/autoload.php';
BOOTSTRAP
%{_bindir}/phpunit --verbose --bootstrap bootstrap.php
+
+if which php70; then
+ php70 %{_bindir}/phpunit --verbose --bootstrap bootstrap.php
+fi
%else
: Tests skipped
%endif
+%clean
+rm -rf %{buildroot}
+
+
%files
+%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -184,5 +201,8 @@ BOOTSTRAP
%changelog
+* Tue May 31 2016 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- add backport stuff for remi repository
+
* Fri May 20 2016 Shawn Iwinski <shawn@iwin.ski> - 2.8.0-1
- Initial package