summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..63d3b51
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,12 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
+composer:
+ tar xf $(shell spectool -l $(NAME).spec | head -n 1 | sed -e 's:.* ::' | sed -e 's:.*/::') --strip-components=1 '*/composer.json'
+ test -d Cache && mv Cache/composer.json src/Cache && rmdir Cache
+ test -d EventDispatcher && mv EventDispatcher/composer.json src/EventDispatcher && rmdir EventDispatcher
+ test -d HttpClient && mv HttpClient/composer.json src/HttpClient && rmdir HttpClient
+ test -d Service && mv Service/composer.json src/Service && rmdir Service
+ test -d Translation && mv Translation/composer.json src/Translation && rmdir Translation
+