summaryrefslogtreecommitdiffstats
path: root/php-symfony-contracts.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-11-05 14:50:54 +0100
committerRemi Collet <remi@remirepo.net>2019-11-05 14:50:54 +0100
commitff262c29340e6b7a187e66a41d26fba75389a12b (patch)
treeb947ea8bb8a6b039b21c5632820a2e9efe2d0647 /php-symfony-contracts.spec
parent023953796579f3b93400a755c7e6e3e7cebfd1b5 (diff)
- update to 1.1.7
- add missing EventDispatcher and HttpClient directories - add weak dependency on psr/event-dispatcher
Diffstat (limited to 'php-symfony-contracts.spec')
-rw-r--r--php-symfony-contracts.spec19
1 files changed, 14 insertions, 5 deletions
diff --git a/php-symfony-contracts.spec b/php-symfony-contracts.spec
index 496df07..ec8cbd1 100644
--- a/php-symfony-contracts.spec
+++ b/php-symfony-contracts.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 2d19b12caccbd80cf0c85624dc87b7021a0df1d5
+%global gh_commit 9cb52490dd60e0f50dbcdbdb3a6dbcb31f3a363e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner symfony
%global gh_project contracts
@@ -21,7 +21,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{pk_vendor}-%{pk_project}
-Version: 1.1.3
+Version: 1.1.7
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A set of abstractions extracted out of the Symfony
@@ -71,8 +71,9 @@ Requires: php(language) >= 7.1.3
# "symfony/translation-implementation": ""
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >=8
-Recommends: (php-composer(psr/cache) >= 1.0 with php-composer(psr/cache) < 2)
-Recommends: (php-composer(psr/container) >= 1.0 with php-composer(psr/container) < 2)
+Recommends: (php-composer(psr/cache) >= 1.0 with php-composer(psr/cache) < 2)
+Recommends: (php-composer(psr/container) >= 1.0 with php-composer(psr/container) < 2)
+Recommends: (php-composer(psr/event-dispatcher) >= 1.0 with php-composer(psr/event-dispatcher) < 2)
# remirepo:1
%endif
# From phpcompatinfo report for version 1.1.0
@@ -109,6 +110,7 @@ do
mv $i $(dirname $i)_$(basename $i)
done
+
%build
: Create autoloader
cat <<'AUTOLOAD' | tee autoload.php
@@ -120,14 +122,16 @@ require_once '%{php_home}/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Dependencies::optional([
'%{php_home}/Psr/Cache/autoload.php',
'%{php_home}/Psr/Container/autoload.php',
+ '%{php_home}/Psr/EventDispatcher/autoload.php',
]);
AUTOLOAD
%install
mkdir -p %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}
-for i in autoload.php Cache Service Translation
+for i in autoload.php Cache EventDispatcher HttpClient Service Translation
do
+ rm -f $i/.gitignore
cp -pr $i %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/$i
done
@@ -165,6 +169,11 @@ exit $ret
%changelog
+* Tue Nov 5 2019 Remi Collet <remi@remirepo.net> - 1.1.7-1
+- update to 1.1.7
+- add missing EventDispatcher and HttpClient directories
+- add weak dependency on psr/event-dispatcher
+
* Thu Jun 6 2019 Remi Collet <remi@remirepo.net> - 1.1.3-1
- update to 1.1.3