summaryrefslogtreecommitdiffstats
path: root/php-simplesamlphp-saml2_3.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-05-22 13:03:56 +0200
committerRemi Collet <remi@remirepo.net>2019-05-22 13:03:56 +0200
commit956b2a0c2b6051a39ad3742064c02f73a2b3e8e1 (patch)
treecb59771e8920e61ccb62dc6968e1f8ea69485e53 /php-simplesamlphp-saml2_3.spec
parent2effd2c825f4b4ddbfcaf0243019a59028fc4463 (diff)
v3.4.1 from Fedora
Diffstat (limited to 'php-simplesamlphp-saml2_3.spec')
-rw-r--r--php-simplesamlphp-saml2_3.spec24
1 files changed, 18 insertions, 6 deletions
diff --git a/php-simplesamlphp-saml2_3.spec b/php-simplesamlphp-saml2_3.spec
index 80fb3e6..ff283ca 100644
--- a/php-simplesamlphp-saml2_3.spec
+++ b/php-simplesamlphp-saml2_3.spec
@@ -12,8 +12,8 @@
%global github_owner simplesamlphp
%global github_name saml2
-%global github_version 3.3.8
-%global github_commit 43753d180f12f7159188995916dc2bbf6ae191b6
+%global github_version 3.4.1
+%global github_commit 4faed2faa324f96e5082146933fc189c0a970074
%global composer_vendor simplesamlphp
%global composer_project saml2
@@ -27,6 +27,9 @@
# NOTE: Min version not 1.0 because autoloader required
%global psr_log_min_ver 1.0.1
%global psr_log_max_ver 2.0
+# "webmozart/assert": "^1.4"
+%global webmozart_assert_min_ver 1.4
+%global webmozart_assert_max_ver 2.0
# "robrichards/xmlseclibs": "^3.0"
%global xmlseclibs_min_ver 3.0
%global xmlseclibs_max_ver 4.0
@@ -41,7 +44,6 @@ Version: %{github_version}
Release: 1%{?github_release}%{?dist}
Summary: SAML2 PHP library from SimpleSAMLphp (version 3)
-Group: Development/Libraries
License: LGPLv2+
URL: https://github.com/%{github_owner}/%{github_name}
@@ -60,6 +62,7 @@ BuildRequires: php-composer(phpunit/phpunit)
BuildRequires: (php-composer(mockery/mockery) >= %{mockery_min_ver} with php-composer(mockery/mockery) < %{mockery_max_ver})
BuildRequires: (php-composer(psr/log) >= %{psr_log_min_ver} with php-composer(psr/log) < %{psr_log_max_ver})
BuildRequires: (php-composer(robrichards/xmlseclibs) >= %{xmlseclibs_min_ver} with php-composer(robrichards/xmlseclibs) < %{xmlseclibs_max_ver})
+BuildRequires: (php-composer(webmozart/assert) >= %{webmozart_assert_min_ver} with php-composer(webmozart/assert) < %{webmozart_assert_max_ver})
%else
BuildRequires: php-composer(mockery/mockery) < %{mockery_max_ver}
BuildRequires: php-composer(mockery/mockery) >= %{mockery_min_ver}
@@ -67,11 +70,13 @@ BuildRequires: php-composer(psr/log) < %{psr_log_max_ver}
BuildRequires: php-composer(psr/log) >= %{psr_log_min_ver}
BuildRequires: php-composer(robrichards/xmlseclibs) < %{xmlseclibs_max_ver}
BuildRequires: php-composer(robrichards/xmlseclibs) >= %{xmlseclibs_min_ver}
+BuildRequires: php-composer(webmozart/assert) < %{webmozart_assert_max_ver}
+BuildRequires: php-composer(webmozart/assert) >= %{webmozart_assert_min_ver}
%endif
BuildRequires: php-dom
BuildRequires: php-openssl
BuildRequires: php-zlib
-## phpcompatinfo (computed from version 3.3.8)
+## phpcompatinfo (computed from version 3.4.1)
BuildRequires: php-date
BuildRequires: php-filter
BuildRequires: php-libxml
@@ -87,16 +92,19 @@ Requires: php(language) >= %{php_min_ver}
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(psr/log) >= %{psr_log_min_ver} with php-composer(psr/log) < %{psr_log_max_ver})
Requires: (php-composer(robrichards/xmlseclibs) >= %{xmlseclibs_min_ver} with php-composer(robrichards/xmlseclibs) < %{xmlseclibs_max_ver})
+Requires: (php-composer(webmozart/assert) >= %{webmozart_assert_min_ver} with php-composer(webmozart/assert) < %{webmozart_assert_max_ver})
%else
Requires: php-composer(psr/log) < %{psr_log_max_ver}
Requires: php-composer(psr/log) >= %{psr_log_min_ver}
Requires: php-composer(robrichards/xmlseclibs) < %{xmlseclibs_max_ver}
Requires: php-composer(robrichards/xmlseclibs) >= %{xmlseclibs_min_ver}
+Requires: php-composer(webmozart/assert) < %{webmozart_assert_max_ver}
+Requires: php-composer(webmozart/assert) >= %{webmozart_assert_min_ver}
%endif
Requires: php-dom
Requires: php-openssl
Requires: php-zlib
-# phpcompatinfo (computed from version 3.3.8)
+# phpcompatinfo (computed from version 3.4.1)
Requires: php-date
Requires: php-filter
Requires: php-libxml
@@ -137,6 +145,7 @@ class_alias('\\SAML2\\Constants', 'SAML2_Const');
\Fedora\Autoloader\Dependencies::required(array(
'%{phpdir}/Psr/Log/autoload.php',
'%{phpdir}/RobRichards/XMLSecLibs3/autoload.php',
+ '%{phpdir}/Webmozart/Assert/autoload.php',
));
AUTOLOAD
@@ -169,7 +178,7 @@ sed 's/function testToString/function SKIP_testToString/' \
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in php %{?rhel:php55 php56} php70 php71 php72 php73; do
+for PHP_EXEC in php %{?rhel:php55 php56 php70} php71 php72 php73 php74; do
if [ "php" = "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --configuration=tools/phpunit --verbose || RETURN_CODE=1
fi
@@ -189,6 +198,9 @@ exit $RETURN_CODE
%changelog
+* Tue May 21 2019 Shawn Iwinski <shawn@iwin.ski> - 3.4.1-1
+- Update to 3.4.1 (RHBZ #1688285)
+
* Wed Feb 13 2019 Shawn Iwinski <shawn@iwin.ski> - 3.3.8-1
- Update to 3.3.8 (RHBZ #1600514)